Trouble Installing Etcher and Ape on Manjaro

It is always returned to install button whenever i have tried to install this app , and it said that Error: A failure occured in build().

I tried this installation on manjaro kde and failed even though my pc spec is not lower than the requirements of manjaro installation. please help me, guys!

Hi and welcome,

This indicates you are attempting to build a package from the AUR (Arch User Repository).

Are you familiar with the AUR?

Most pointedly - have you installed the prerequisites for using the AUR?


The following guide may be helpful when asking for support. Such as how to format code, etc.

1 Like

Hello everyone,

I’m having trouble installing Etcher and Ape on my Manjaro system. Whenever I try to build Etcher from the AUR, I get an error message saying “Error: cannot find the fakeroot binary.” Here’s some additional information:


  • I’ve enabled both AUR and Flatpak repositories.
  • I’ve tried reinstalling Manjaro KDE three times to rule out any mistakes on my part.
  • Interestingly, while I can somewhat install Etcher on Manjaro KDE, the process is more challenging on Manjaro GNOME.

Here are some screenshots which should be concluded , I think.

By the way, I’m new to linux, manjaro gnome and so some easy things maybe the whole problems for me.

I’d appreciate any advice on resolving this issue. Thank you for your help!

Open AUR wiki page (either Manjaro or Arch one) and read what prerequisites for using AUR are.

1 Like

I’m fairly certain that checking “Enable AUR Support” does not suffice.

A precondition to using it is to have the package group base-devel installed.
All the programs in it.
It contains all the programs needed for building AUR packages - fakeroot among them.


Consider Ventoy. I don’t know if it’ll work for your situation, but I think it could be an alternative.

1 Like

Balena Etcher has Appimages ready for download on their site. In that case i would recommend this, but this is an exception.

And i would not recommend the use of aur for absolute beginners…you have not even started with it and you had a problem, imagine if something is not working or an update breaks because of it.


Ape builds fine on Manjaro

pamac build ape

As for etcher - I don’t know I wouldn’t dream of installing it - bad reputation - I don’t know if that is true for today - in any case use something else - like mintstick - or even better ventoy.

1 Like

Your duplicate post has been merged into your original, which very much appears to be the same ‘issue’.
Please review the AUR wiki page linked above.

1 Like

Actually I only need Ape ape. whenever i install with terminal or add/remove app, it is not working because tclkit and sdx are missing. I did update but it is not working. I am still hopeless to use. Could you find me a easy way to solve this problem?

AUR packages won’t build themselves. It’s your responsibility to install what’s needed from AUR.

I already did

pamac can build this including buildling the dependencies from AUR.

The recipe is quite simple

sudo pacman-mirrors -aS unstable
sudo pacman -Syu git base-devel --needed
pamac build ape
1 Like

Thank you so much bro.
even though the commands are perfect, I have downloaded tcl manually in browser because there is still error to download fully.
By the way, This community is so helpful.
I almost go to window again if it doesn’t work properly.

Thank You for your patience bro

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.