Trouble connecting monitor to laptop via HDMI

there is no problem until now, but I’m not sure it will last, because it was not working before reinstalling VirtualBox, so I did not solve the issue, there were problems with 6.1 the issues were solved without adding the acpi parameter.
I will test it furthermore today and tomorrow before the topic close.
I’m so grateful for you @brahma, you saved me a lot of time and depression, and you made my day

i just add to check if fast boot is disabled in bios - you may not have this option;
and fast startup disabled in windows

I disabled fast boot on windows a week ago, but I can’t find the fast boot option in bios settings.
The monitor working properly but one time it didn’t work I rebooted the laptop without changing anything it worked, wired isn’t it :confused:.

so maybe theres something that doesnt sit well with the 6.1 kernel, so use the 5.15, or switch to the 6.2, and see how that one works…

1 Like

I did the following:

  • Install Linux 6.2, and reboot the laptop, the monitor does not work even after replugging the HDMI cable
  • shutdown then booting using Linux 5.15, the monitor does not work even after replugging the HDMI cable
  • removing Linux 6.2, and reboot the laptop, boot using Linux 5.15 the monitor works properly after replugging the HDMI cable twice
  • reboot the laptop, and boot using Linux 6.1 the monitor does not work, replugging the cable three times works.

  • is video-hybrid-amd-nvidia-prime PRIME like named ?, What I know is that PRIME is an alternative to Optimus manager, so I’m using PRIME and Optimus manager at the same time, does that make issues and conflict

those are hybrid drivers, and they are not in conflict with optimus, optimus is being used to switch between gpus, and we installed it mainly because you mentioned that previously installing optimus helped …
there is something not right here, maybe its a manjaro thing, so i would try to boot into live usb of for example endeavour with proprietary drivers of course and see if it works there out of the box…

1 Like
  • I don’t have endeavour ISO so I tried Kubuntu which I have, but Kubuntu does not load the GPU drivers without installation, and I can’t boot with open-source drivers or proprietary drivers like Manjaro.
  • the internet in my country is limited, so I can’t download endeavour, I pay for every Gigabyte I use.
    I’ll wait until I go to a cafe or somewhere I can use the internet without affecting my home quota
1 Like

@brahma, endeavour works appropriately out of the box.
Now Manjaro works but not consistently, sometimes the monitor does not work then I try to reboot the laptop a couple of times (without changing any configuration or settings) then replugging the monitor and it works.

so if endeavour works out of the box without any monitor issues, i would suggests to install it…

1 Like

honestly, I don’t want to leave Manjaro, I’ve been using it for a long time.
If someone can help me diagnose the problem I’ll be so grateful, maybe it’s mhwd

The issue has been fixed.

  • before mentioning the solution there was another problem I want to indicate, There was a huge latency when using the external monitor only, but this problem does not happen when using both monitors or the laptop monitor only.

  • there are two things I did I don’t know which one fixed the issue

  1. remove /etc/X11/mhwd.d/nvidia.conf
  2. installing OpenGL
  • I didn’t install OpenGL by myself I was installing an AUR package that installed OpenGL

  • after these two things happened the two issues have been solved

  • I’m very happy not leaving Manjaro, Thanks to you all, specially @brahma

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.