Trouble configuring hibernation

Hello to all lovers of computer hardware and codes. I am a regular user who has decided to change from Windows to Linux. I have a serious problem: I cannot configure hibernation. This applies both to the swapfile I tried to use and the partition that I already created automatically. After all the attempts, I chose to install the system with automatic disk partitioning. In this case, you can turn on the ready-made hibernation. It happens to me like this: when I turn it off for verification, the system is restored without problems. For a short time, a few hours, too, no problem. If I turn it off until the next day, a black screen and a stationary cursor appear, Caps Lock may blink at the same time. We have to cut down the laptop with the power button.
Here’s what I have:


GRUB_CMDLINE_LINUX_DEFAULT = “quiet apparmor = 1 security = apparmor resume = UUID = a1c1057d-8a94-4068-a828-20733fce823c udev.log_priority = 3”


HOOKS = “base udev autodetect modconf block keyboard keymap resume filesystems”

/ etc / fstab:

UUID = a1c1057d-8a94-4068-a828-20733fce823c swap swap defaults, noatime 0 2

$ inxi --full --admin --verbosity=7 --filter --no-host

System: Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=26ba52d4-2296-436e-9b31-4fe7b1c0fd7f
rw quiet apparmor=1 security=apparmor resume=UUID=a1c1057d-8a94-4068-a828-20733fce823c
Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: G5 5590 v: N/A serial: Chassis: type: 10
Mobo: Dell model: 0KW84T v: A01 serial: UEFI: Dell v: 1.11.1 date: 11/11/2019
Battery: ID-1: BAT0 charge: 27.7 Wh condition: 56.6/60.0 Wh (94%) volts: 14.7/15.2
model: BYD DELL HYWXJ02 type: Li-poly serial: status: Discharging
Memory: RAM: total: 7.59 GiB used: 3.08 GiB (40.6%)
RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU: Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake family: 6
model-id: 9E (158) stepping: A (10) microcode: D6 L2 cache: 12.0 MiB bogomips: 62431
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800
6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2
bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm
dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp
hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca
mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq
pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep
smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:3e9b
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell driver: nouveau
v: kernel bus ID: 01:00.0 chip ID: 10de:1f91
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:2
chip ID: 0c45:671f
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel,modesetting,nouveau
alternate: fbdev,nv,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.8 direct render: Yes
Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:10fa
Sound Server: ALSA v: k5.8.16-2-MANJARO
Network: Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000
bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: up mac:
IP v4: type: dynamic noprefixroute scope: global broadcast:
IP v6: type: noprefixroute scope: link
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169
v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Argument “fuse.gocryptfs” isn’t numeric in numeric eq (==) at /usr/bin/inxi line 12906.
Drives: Local Storage: total: 238.47 GiB used: 177.83 GiB (74.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 vendor: A-Data model: IM2P33F3 NVMe ADATA 256GB size: 238.47 GiB
block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial:
rev: 91002105 scheme: GPT
Message: No Optical or Floppy data was found.
RAID: Message: No RAID data was found.
Partition: ID-1: / raw size: 230.00 GiB size: 225.39 GiB (98.00%) used: 177.83 GiB (78.9%) fs: ext4
dev: /dev/nvme0n1p2 label: N/A uuid: 26ba52d4-2296-436e-9b31-4fe7b1c0fd7f
ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1 label: N/A uuid: 9613-4811
Swap: Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 label: N/A uuid: a1c1057d-8a94-4068-a828-20733fce823c
Unmounted: Message: No unmounted partitions found.
USB: Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s
chip ID: 1d6b:0002
Device-1: 1-5:2 info: Microdia Integrated_Webcam_HD type: Video driver: uvcvideo interfaces: 2
rev: 2.0 speed: 480 Mb/s chip ID: 0c45:671f
Device-2: 1-14:3 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: Bluetooth
driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aaa
Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003
Sensors: System Temperatures: cpu: 35.0 C mobo: N/A gpu: nouveau temp: 28 C
Fan Speeds (RPM): N/A
Info: Processes: 290 Uptime: 1h 18m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages:
pacman: 1240 lib: 349 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

I would be grateful for your help, because the problem is critical for me. I’ll have to ditch Manjaro if it doesn’t fix it. It’s a pity the time spent on mastering the system, especially since I like it.
I apologize for the automatic translation if something is not clear.

Hello @ost_ld !

A question to verify: Are you really using hibernation or just suspend?

Please try these commands:

systemctl suspend


systemctl hibernate

The configs are looking good so far, but some systems, idk why (at least on my workstation i need this, otherwise it didn’t work), need to put resume after udev like that:

HOOKS=“base udev resume ...”

then run:

sudo mkinitcpio -P

Yes, I am using hibernation. I use Suspend when I close the lid of the laptop during the day, and at night I turn it off and save the state to disk.

systemctl suspend worked as expected, but systemctl hibernate did not. The same thing happened: Caps Lock flashes and there is no reaction to my actions, but at the same time the screen of the state that was before the shutdown came on. I have not had this before, and only a black screen appeared.

Previously, I already set resume after udev according to the instructions on, and in this form the line appeared after the automatic installation, that is, when the swap partition and hibernation were made by Calamaries himself.

But I did it again on your advice and changed the words. Booted fine. However, I cannot say if the problem is solved, because I need to check it for a while. As I said, I checked the hibernation without problems, but after a significant amount of time the state did not recover.

Unfortunately, the problem still remains. My laptop with the flashing Caps Lock failed to turn on again. Is there anything else you can do to help?

I don’t know if this will be useful: when I update grub I always have this: usr / bin / grub-probe: warning: unknown device type nvme0n1

For testing, I put the system on another disk (HDD), transferred / home, and my problem disappeared. Any idea what this means?