Trouble Booting 20.2 on Raspberry Pi 4b 8GB

I’ve been trying to boot the latest versions of Manjaro with no success. Tried booting XFCE and KDE Plasma on a 128GB SD card at first, and then a 32 GB card. I have not been able to get past the initial Raspberry Pi boot page, the following is presented on the screen:

Raspberry Pi 4 - 8 GB
bootloader: c305221a
config: 86697050
board: d03114 9d3b847f dc : a6 : 32 : d5 : d7 : 95
boot: mode SD 0 order 1 retry 3/3 restart 0/-1
SD: card detected 00035344534b33324870b1f583950149
part: 0 mbr [0x00:00000040 0xef:005c790c 0x00:00000000 0x00: 00000000]
updates: enabled 0
net: down ip: sn gw:
tftp: 00:00:00:00:00:00

Partition: 0
Partition: 0
Partition: 0
Partition: 0
Insert SD-CARD

Not sure why my Pi is having trouble recognizing the SD card. I’m going to try running raspbian next to make sure I can get SOMETHING to work. Any pointers appreciated!

I never have been presented with all of that. If your eeprom has not been flashed with the proper software it will not boot on the usb drive. Did you have your usb drive still plugged in when you tried the sdcard?

It really looks like an improper sdcard flash if no usb drive was plugged in when you tried the sdcard as it says it was detected as then it tried to do a network boot.

Version 20.2? The latest stable version for Manjaro ARM is 20.12.

I got an “SD card not detected” message when trying to use btrfs for the boot partition. Some sources say the version 5.x kernel recognizes btrfs, but that wasn’t true for me. (When using vfat for the boot partition and btrfs for root, the message “btrfs is not recognized” came up when trying to mount root.)

The boot partition has to be vfat. Did you specify the root file system in the /boot/cmdline.txt?

root=LABEL=ROOT_MNJRO rootfstype=btrfs <the rest of the commandline here>

Why did you not supply all of the info in the first post of all of the changes you had made to the original image. Very hard to diagnose when that info was not given until your second post.

I haven’t been doing anything different when I flash this, I’ve successfully flashed ubuntu and raspbian previously. I am somewhat at a novice at booting OS to my Pi though.

I downloaded 20.2 Nibia released 12.3.20

That’s an x86_64 based ISO, not going to work on an aarch64 device, like the raspberry pi.

Please download a 20.12.1 Raspberry Pi Manjaro ARM image and try again.

I experimented with a half dozen or so SD card setups to see if btrfs could be used for the boot or root partition. It was only an experimental exercise. I don’t have a problem to solve, so I didn’t post details As you say, vfat is a must for the boot partition. If the boot partition is not vfat the SD card is not recognized. That is the OP reported error, which is why I mentioned the partition formats. (Also, feeding Nubia to an RPi4 might be a problem.) Thanks for the information about specifying the root partition format in /boot/cmdline.txt, I’ll give that a try when I have some free time. I gave up when the message that btrfs for the root partition is not supported came up.

Something to keep in mind for your testing with btrfs.

As a note, I was successful in using btrfs for the rootfs, so it can be done.