(Triple boot) grub-update new os boot entry showing in terminal but not in grub menu after reboot

i am using manjaro and windows as dual boot. but I want to try fedora os.
so i installed fedora os on other partition as i am doing triple boot.
after running sudo update-grub. fedora os is detected but this entry is not showing in the grub menu after reboot. please help don’t know what to do now.
below is the output of sudo update-grub

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.12-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.12-x86_64.img
Found initrd fallback image: /boot/initramfs-5.12-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.11-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.11-x86_64.img
Found initrd fallback image: /boot/initramfs-5.11-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Warning: os-prober was executed to detect other bootable partitions.
It's output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Found Fedora 34 (Workstation Edition) on /dev/nvme0n1p10
Adding boot menu entry for UEFI Firmware Settings ...

is little helpful, I think.
Try using /etc/grub.d/40_custom for Windofs, and disable OS-Prober.
Fedora … later.

exists in Fedora /etc/default/grub

hi GaVenga thanks for replaying
here are the points i tried from your suggation:

  1. I tried the solution from your first link it is not working

  2. disabled os prob in grub but after that grub is not detecting any os

  3. checked /etc/default/grub in fedora by mounting it on manjaro there is no any grub file

few points from my side :

  1. i installed fedora on a partition without a boot loader. just root (/) mount

  2. i cant see a fedora entry folder in /boot/efi partition like manjaro and windows have a folder there how can I add fedora entry there.

i have reformated fedora os from 30GB partition here I have one question there :
please see the below screenshots:

as you can see from the above screenshot you can see automatic partition option there
which I did not select earlier

here from the above image, you can see all my existing partitions

after clicking on this automatic option there. it automatically created root, boot partition within this 30GB space.
and it is also detecting existing /boot/efi partition without format option

if I go with this approach will it impact my existing grub menu?
or it will create a fedora entry there?

please suggest as I don’t want any risk now because in existing manjaro I have some work-related dependencies don’t want to loose that

First: Backup any valuable data.
Hope, my second solution works, as one of the last postings tells “solved”.

The parts for Manjaro linux should be in /boot/grub/grub.cfg
Chainloading of ONE system is required AFAIK.
(One system is the Big Boss - the other the humble slave)
and so on…
the /boot/efi/ of manjaro must be used - finaly even Windoofs uses this location
if started from Manjaro by chainloading (that is the normal way).
Do not format existing /boot/efi/ partition - “use” is the correct thing…
nvme0n1p8 is your master.

1 Like

Add GRUB_ENABLE_BLSCFG=false to /etc/default/grub in ur fedora installation and update grub in Fedora. If it is already in there then change ‘true’ to ‘false’ and update grub in fedora


Thanks.2nd option of automatic partition worked.
ON BIOS UEFI menu i can see fedora entry along side manjaro. By changing boot order i can boot in to fedora.
But manjaro grub menu still not displaying fedora entry don’t know why.

And but from fedora grub menu i can see manjaro , windows . But manjaro is not booting from fedora stuck on black screen.

Anyway i just want to boot and test os on small partition. not using this for regular usage

1 Like

Try: sudo update-grub first from Manjaro and then from Fedora?

after doing this i can see fedora entry in manjaro grub . thank man :grinning:

by the way what is GRUB_ENABLE_BLSCFG mean ?


Welcome :smiley:


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.