Tried to update nvidia driver, system boots to black screen with no tty access. Chroot went black as well


I wanted to play the new juicy Cyberpunk 2077 and found I had to update my nvidia drivers from 450xx to 455xx.

I tried to do this in the terminal (i am using an architect install).

hardware: ryzen 5 3600, nvidia 1660 ti

I am using the 5.8 kernel, but I believe I also have 5.4 installed, though the live usb I am chrooting from seems to have 5.6…

I tried to run something like ‘sudo pacman -S nvidia-455xx’ and found I could do a system update so I did (its been a while and ive just moved, it was kinda big). probably was a little too hasty here.

after this I tried to install the new nvidia driver again and rebooted.

on reboot, I go straight to a black screen. I think it has to do with X and the kernel/driver versions. I select the partition in BIOS, it seems to ‘boot’(fans sound normal) but no output on screen. I could not even switch tty with ‘Ctrl + Alt + f2/3/4/5’

I downloaded the architect iso trying to chroot into system and uninstall the old nvidia driver and replace it. I saw I had both installed (450xx and 455xx) and i ran ‘sudo mhwd -r pci video-nvidia-450xx’ and then immediately ‘sudo mhwd -a pci nonfree 0300’ (I think this was wrong too according to manjaro forum :frowning:

It seemed to uninstall the 450xx driver just fine but when I installed the 455xx driver, the screen went blank again in chroot.

I have removed the 455xx driver and added the 450xx driver. ‘pacman -Ss | grep nvidia’ shows me a bunch of drivers still but mhwd -li shows me just video-linux and 455xx driver. all of this in chroot, closely following link posted above. I still do not get any screen output after selecting partition in bios

there seems to be no way to access my system outside of chroot.

What can I do to safely fix these mistakes? I want to not be so hasty and make sure I am doing the right thing.

Hi @dddonehoo :wink:

  1. Remove all nvidia drivers:
mhwd -r pci  video-nvidia-450xx
mhwd -r pci  video-nvidia-455xx
  1. Keep sure really everything has been removed:
pamac list --installed | grep nvidia | grep -v mhwd
  1. Check the Xorg.conf files:
ls /etc/X11/xorg.conf.d/

if there is a nvidia or mhwd one, better remove it or move it to another place.
4) Install the driver cleanly:

mhwd -i pci video-nvidia-455xx

That should fix it if you are on stable branch.

1 Like

I tried this and I am still getting a black screen on boot. The only thing that stuck out in the process is a modprobe error. It says it cant find the module ‘nvidia-drm’ in the modules folder for the 5.6 kernel, I only have the 5.4 and 5.8 kernels installed but the live usb seems to be using 5.6. Could this be a problem?

ah, I think i found more important information!
In the xorg log it says it is unable to initialize the nvidia kernel module.
When I try to run ‘sudo modprobe nvidia’ its looking in the 5.6 kernel directory, becuase the uname -r command in chroot returns that. I think it should be looking in the kernel directories of the host right? Can I initialize kernel modules from chroot?

That is an old ISO. Use the latest one.
5.6 and 5…8 kernels are EOL (end of life). Install 5.9 kernel from TTY and boot from it.
sudo mhwd-kernel -i linux59