Tried to fix Suspend mode. Broke both login and screen lock instead

Two or three weeks ago I started suffering from the “when computer goes to Suspend mode and you log back in, the screen turns black with a functional mouse cursor” issue.

Someone found something that fixed it for them:

sudo pacman -S lxdm
sudo systemctl enable lxdm.service --force

However, this didn’t work for me. Instead, it messed up my login screen and broke my computer’s ability to lock the screen (and apparently to go to Suspend, too).

Uninstalling lxdm just changed the login screen even further (now it just boots into the terminal), and didn’t restore my computer’s ability to lock the screen or go to Suspend.

Can anyone tell me how to undo the damage that installing and forcing lxdm did?

It was suggested to me to disable all these features and then “force lightdm”, but I’m not sure how to do that last bit. If I had to guess, it’d be the same second line except with lightdm instead of lxdm, but I know better than to try to guess. Even with clear instructions, it’s so easy to break things. A guess is nowhere near good enough.

What you did was install and enable another Display Manager (DM) … which is the thing that you use to login/launch your Desktop Environment (DE).

Why that would be a solution for suspend … is a mystery to me.

But also … you already have a display manager. lightdm.

Having both would be a problem … and again … I dont know why you would want lxdm … so … remove it ?

Package removal

sudo pacman -Rns lxdm

Make sure the service is gone

systemctl disable lxdm --now

You didnt mention removing lightdm … but just in case, heres reinstalling what you had

sudo pacman -Syu lightdm lightdm-gtk-greeter lightdm-gtk-greeter-settings

Now you probably just want to enable lightdm

systemctl enable lightdm

I dont know why ‘force’ would be required … but since you did it before and mentioned it again …

systemctl enable lightdm --force


1 Like

Whew, that fixed the lxdm problems! Thanks!

I’m stuck with the black screen issue again, but I guess that’s a problem I’ll have to fix separately. In the meantime, when my screen gets locked and I came back and get the black screen, I can use Ctrl+Alt+F2 to go to the terminal and log back in from there, then restart the GUI. It’s a pain, but you gotta do what you gotta do.

Ah, yes, the fix (besides having worked for that particular person) seemed legit because there’s an option in the Power Manager to switch power management (the settings that determine when the computer screensaves, locks screen and goes to Suspend) handling from DPMS to X11, but I had no idea what X11 was or how to access it. lxdm’s description is that it’s a “Lightweight X11 Display Manager”, so I thought that user was telling me that it would give me access. Now I’m guessing lxdm is not “a thing that displays a manager for X11”, but rather that it’s “an X11-based display manager”, or something along those lines. Who knows. Not me, and at this point I don’t want to know.

I have no idea why they thought I needed to “force” it, and indeed, I didn’t need to force lightdm when I reenabled it.

Thanks again!

Now I have to figure out how to make a decent post describing this “black screen after entering password from screen lock” issue. When you ask people for help, ideally you make an effort to make it as easy as possible for them to understand what the problem is, and include all relevant information that may be needed to identify the issue.

I will still explain it to you, because its simple :smiley:
Lightdm, like the (DM) at the end says, are Desktop manager.
Means, they are the Login-Screen when you load the system. then you got this window where you can choose your User and your Desktop, like when you have KDE Gnome or X11 parallel installed.
Other distros offers other Desktop-Enviroments like Cinnamon, Pantheon and others.
You can find more about it with a search about “Linux Desktops”.

That problem with the black screen and only mousepointer left seems is a XFCE related problem, i can only suggest to use KDE or Gnome until they fix that.
I am not happy, that they now mess up XFCE, they did once with KDE with her limited root access, because one from this ‘smart developers thought’ “Users should not have root access, because they mess up so much things”, but actually, you have to have that, because of all of her bugs,
and now there is again a Genius what mess around at XFCE.
Today i tried KDE and Gnome, at both Desktops suspend and wake up works normal.
Just XFCE makes further problems, even i thought it fixes it, when i switch at power management at system to suspend mode, not sleep mode. But it only works at 2 of 3 attempts.

Random tip:

AFAIK the suspend functionality is handled by the kernel. Or a combination of that and systemd. I currently have only 1 kernel whose suspend is working properly for my PC, so that’s what I’m sticking to. At least for now.

So make :100: the same kernel is installed in the other versions as well…

I will keep that in mind when I make my post about it, maybe it will help narrow the problem down.

When I tested whether or not the Lock Screen functionality was back, I didn’t leave it long enough to go to Suspend (unless it did that behind my back when I asked for Screen Lock) and the problem happened anyway, so I’m not sure it’s Suspend doing it.

Additionally, when the black screen happens and use Ctrl+Alt+F2 to log back in, the Lock Screen functionality doesn’t work anymore.

Very strange.

XFCE is not broken for everyone. There is likely a local system issue.
Suggesting to just use a different DE is not really a solution.

What a bunch of hooey.
Nothing has been broken …

I think you are referring to Plasmas general disallowance of running GUI application with sudo.
Which is nothing new and good design. You shouldnt do that. For so many reasons.

Including but not limited to … you dont need it. kate will prompt for credentials if you edit and attempt to save a system file that requires privileges.

… and it sounds like all of your wisdom has gotten you to a broken situation yourself. Whether from mixing multiple DE’s, or by using sudo frivolously. Or something else.

Who knows … but please dont spread your zany and unfounded ideas to the innocent public. Thanks.

@unfortunately glad you are at least back to where you were.
Yes, it would be good to start another thread with your suspend problem.

If you would use 2 minutes of research at the net, you can find, that its an issue since 2018 occasionally at different distros.
And its not only XFCE related.
Do i need to google it for you or can you manage it by your own to show you examples.

I was refering to this self-claimed KDE-Rambo Martin Grässlin, who decided to strip Dolphin to run it with root rights and nothing about running programs with sudo.

At this time 2017 there was always something broken
You are kidding when you claim at Linux is “nothing broken” because there is all time something broken as you see with every update.
Example before some months, my screen also stayed black after suspend, why? Because i suddenly had to connect it to Out1 instead of Out2.

Is that all of “Your Wisdom” what you get, when you put some assumptions about, what i did or not?
Even you can see it, when you would do the search about “Black screen with mouse pointer at XFCE”
But now its my fault because you wish so?

I did not mix Desktops before it happened.
I have an other system on an other HDD, what was last updated before 1. Dec 2023, and it does not happen there.
All i did was updating, and it happened suddenly.
This system was even pretty newly installed and i don’t play a lot around to mess things up, i use my programs what i need and that’s it.

Well, please stay at a neutral language when you are not affected by this problem.

I will suggest, what i think is the best, since no one is able to fix that bug and its a very annoying bug,
where it seems, that it happens all time again with XFCE.
There are 2 other Post about it,
once, where even switch to TTY cause a black screen, the other, where you log on with 2 Users, stay at one for about a minute, then switch back to the other user and this black screen appears and i can even reproduce it.

I somehow managed sometimes even that the screen suddenly did come back to normal by ie pressing keys like ctrl+alt+tab, that tells me, there is clearly something wrong with XFCE’s code.

Mirdarthos above guessed, lts the Kernel modules, what control suspend mode.
So did i at the beginning, because it happened after an update from Kernels, not sure, if it also was nvidia 535 → 545.
But actually, the suspend mode works, when you do it at TTY and press again a key, the system wakes up normal to the TTY.
I can not say if there is a call from the Kernel to X11 or X11/XFCE manages it all by itself.

But since XFCE should work with multiple users at the same time (ie, 2 or more Screens, Keyboards, mices) to work at the same time, such an problem is really annoying and they can not fix it.
So its better, to switch to an other Desktop so far that problem exist, because bothering with it to much seems will be a dead end.

No, my friend …

“Black screen with cursor” is not some single ‘bug’.

Its an error encountered, sure … but if it were just a “xfce doesnt work after update 3.11” … then we would all know it.

I wont even grace the dodo article with a click … that person is famous for having ridiculous expectations and creating flame reviews based on their own warped criteria.

If you dont know how to handle system files without a GUI I daresay you shouldnt be touching those files … but theres also less destructive ways to use a GUI to do so than by ‘running dolphin as root’ or whatever other thing you think should be possible because you are simply inexperienced.

Thats not a character flaw … until you use it as armor against any further enlightenment or try to pollute others.

By the way I never said ‘nothing is broke on linux’ … thats like saying ‘science is done’.
I said “XFCE is not broken for everyone” … because it isnt. You seem to be conflating every graphics error ever experienced by any user into some single ‘brokenness’… which is just so flagrantly out of touch with how things work I dont know where to begin.
If you have some monolithic bug tracker to point to where XFCE “broke” please share it.

Sorry to say, I am running manjaro (and other) xfce, and only xfce for around 10 years now.
There is nothing broken in lightdm, light-locker or xfce4-screensaver, with or without nvidia.
You just messed up your configs.
Tip: Start new, this time with attention on what you are doing.

Well you put out again an assumption. Cant you live without it ?

That even was the joke about Martin Grässlin. He restricts Dolphin, but you can easy access files in other ways, just some more unpleasent. And that was, what a lot from the community didnt like on this decision.
Linux should not be a system what is build on restrictions, but let people learn about it, and they will, as more as they work deeper with it.

I dont know, what you are talking about, but even at one page someone came to the same conclusion then me, and that was set at Powermanagent suspend mode instead sleep.
I pointed out, that the exact same error exist since a long time and all time pretty similar. There is not much space to spread it on much possibilities.
And seems most time, they end up by reinstalling the Desktop, so, they are not really on the root from the problem.
But i bet anyway, you even did’nt research, since you seems you are more in a hurry to reply here.

At least, there is now another post about nvidia 545.20.06, where they say, its nvidia related.
Maybe its fixed next week with a new update.
Just strange, it happens here with XFCE and not Gnome.

You still are missing the basic points.

For example … there are reasons software like gksudo were abandoned and are not found in the repositories.

Doing sudo dolphin is even worse.

And none of this is helpful to the already solved thread.

1 Like

Oh? I am sooo sorry, that you had to reply and bload up the thread.
You even could had stop before your last post. Why dont you do that now?
I said all, what i know right now about the Black screen problem.
And all you do is to moan about it. Great work!

I didn’t do anything, though.

For the last five years, whenever I locked the computer screen to go out or for the night, or if I forgot it and the automation on the settings did it for me… I could just come back, input my password, and I’d be right back on my DE.

But a couple weeks ago, when I input my password on Screen Lock after going away, I found myself facing a black screen with a functional mouse cursor. From there I can use Ctrl+Alt+F2 to get back to a login screen and reenter my DE, but if I do that, my Screen Lock function doesn’t work anymore.

Some update must have some quirk that my system can’t handle, but I really don’t think I personally did anything wrong. Because I didn’t do anything at all.

Where we can properly diagnose it.
(Not to mention most people will have ignored this since being solved already.)
Maybe you ignored pacnew files?
We will see …

I don’t know what that is.

But yes, I’ll start a new thread right now. It’s not going to be as polished as I’d normally like, but I’m going to have to figure out what happened eventually if I ever want to be able to lock my screen again.

Edit: done.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.