Trash problems in KDE

Hi All,
I’m running KDE and my system is up to date.

I deleted a bunch of files and the received a “Trash is full” message when trying to delete another file.
I opened Trash to empty it but it said Trash Empty.

I tried rebooting but that didn’t help.

I changed the Trash config settings to delete the largest file instead of giving a “Trash Full” message.

Then I deleted the other file and all worked well, or so I thought.

I opened Trash again it showed the one file that I just deleted.
When I select “Empty Trash” it will not remove that file.

I am stumped.

Any help that you may provide will be greatly appreciated.

ls -a ~/.local/share/Trash/files

Should show us all the contents.

Dolphin preferences has Trash settings:

Many thanks for your help @cscs, I do appreciate it!

I tried that command and it did not show me anything.
So I opened up Dolphin and took another look and now it shows Trash as being empty… but is it really empty?
Before it said it was full but showed as empty.

Yes I did modify the Trash settings in Dolphin, that’s were I selected Delete Largest file instead of Show Trash Full.
I also selected auto-delete after three days.

So was this just a weird hiccup or is my Trash secretly full?
And no, I’m not full of Sh… :laughing:

Sounds like maybe you were moving large files into trash, it ended up deleting things as requested, and you were viewing it during these operations, and now afterwards (showing nothing).
It would appear it is truly empty now.

Technically there could be more things in Trash;

ls -a ~/.local/share/Trash
ls -a ~/.local/share/Trash/*

Though I expect not.

Maybe, but I did wait (I was watching a video while periodically deleting files), tried several times to clean an empty yet full Trash and rebooted as well.

I’ll chalk it up to Gremlins in the system.

I just used Dolphin to calculate how much free space I have in my Root directory and it seems to think I have 128TiB of total space!
I actually have installed Manjaro on a ~60Gb partition on my 256Gb SSD. I don’t know where it got 128TiB from.

It surprised me the first time I saw it too.