Tracker-miner-fs-3 runs for minutes at *every* search in Nautilus

I use Manjaro Gnome, and I have recently noticed that the process named “tracker-miner-fs-3”, which to the best of my knowledge should run in the background from time to time to index files in my home, is executed every time I try to search something in Nautilus.

Here is what happens: I start typing some search term, search hangs (no results are shown) and in System Monitor I can see tracker-miner-fs-3 running. The process runs for several minutes (no less than 10, with relatively high CPU usage), then it finally stops and the search results are shown. But the next time I try to search something else in Nautilus, no matter how little time may have passed, the same will happen again and again.

In practice, I no longer have a search functionality in Nautilus (because searching takes so much time that it’s more convenient to use another tool, like locate in a terminal) and this also causes battery drain, because tracker-miner is rather resource-hungry.

What is the solution? There is clearly something wrong in tracker miner, but I don’t know how to debug it. Some people suggest removing tracker-miner altogether, but this will prevent Nautilus from performing any search, won’t it?

1 Like

For the moment I have followed the instructions provided here to disable tracker3. Search in Nautilus still works (or, I should say, it’s working again) and the process tracker-miner-fs-3 no longer runs in the background.

I’ve experienced the same error, although I am running KDE unstable.

If you duckgo “tracker3-miners keeps crashing”, you will see a bunch of reports all around.

1 Like

If disabling it doesn’t break any functionality in my day-to-day use, that solution is more than enough for me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.