Tp-link tl-wn823n USB wifi Adapter does not working

My network adapter shows wifi networks but does not connect. I am typing right password. It gives error notification that “connection “name” deactivated” & “WIRELESS INTERFACE (wlp41s043u3)- the wifi network could not be found”. Before manjaro KDE I was using ubuntu and it was working fine but today I installed manjaro and it stopped working. I am still new to linux, so sorry if its a dumb question. Thanks in advance :slight_smile:

Welcome at the forum, @LinuxNewbie :tada:

Please provide the basic information of your system by posting the output of

inxi -Fxxxza --no-host

If you use KDE you can set all your wifi parameters in system setting -> network -> connections. I would assume you have at least to enter the SSID of your network, modus, security method and password. If you use a hidden SSID then mark the corresponding check box. Make sure your router is willing to talk to the MAC address of your computer.

If it’s a driver problem you most likely need to install rtl8192eu driver from AUR as described here as well.

Hi, @Wollie these are the basic information of my system:

 System:    Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=e148303e-b683-45ca-beb1-99714b232cf4 rw quiet 
           apparmor=1 security=apparmor resume=UUID=0fac4fd3-0a8b-42ca-811c-d25e064479c7 udev.log_priority=3 
           Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7C52 v: 1.0 serial: <filter> 
           Mobo: Micro-Star model: A320M-A PRO MAX (MS-7C52) v: 1.0 serial: <filter> UEFI: American Megatrends v: 2.60 
           date: 06/10/2020 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K230 serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP arch: Zen+ 
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28812 
           Speed: 1854 MHz min/max: N/A Core speeds (MHz): 1: 1854 2: 2352 3: 2958 4: 2951 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: Micro-Star MSI driver: amdgpu v: kernel 
           bus ID: 29:00.0 chip ID: 1002:15d8 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.39.0 5.9.8-2-MANJARO LLVM 11.0.0) v: 4.6 Mesa 20.2.2 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel 
           bus ID: 29:00.1 chip ID: 1002:15de 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 29:00.6 chip ID: 1022:15e3 
           Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus ID: 5-1:2 chip ID: 046d:0825 
           serial: <filter> 
           Sound Server: ALSA v: k5.9.8-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.048.03-NAPI modules: r8169 port: f000 bus ID: 25:00.0 chip ID: 10ec:8168 
           IF: enp37s0 state: down mac: <filter> 
           Device-2: TP-Link TL-WN823N v2/v3 [Realtek RTL8192EU] type: USB driver: rtl8xxxu bus ID: 3-3:3 
           chip ID: 2357:0109 serial: <filter> 
           IF: wlp41s0f3u3 state: down mac: <filter> 
           IF-ID-1: enp18s0f0u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 9.89 GiB (1.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A02 scheme: GPT 
Partition: ID-1: / raw size: 922.42 GiB size: 906.94 GiB (98.32%) used: 9.89 GiB (1.1%) fs: ext4 dev: /dev/sda2 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 37.5 C mobo: N/A gpu: amdgpu temp: 37.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 212 Uptime: 28m Memory: 5.81 GiB used: 1.85 GiB (31.9%) Init: systemd v: 246 Compilers: gcc: N/A 
           Packages: pacman: 1221 lib: 357 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

OK, please apply these commands and post the output:

ping forum.manjaro.org
(needs to be aborted after some seconds)

ip link

rfkill

lsusb -v
(only copy here the part of your wifi device)

I ran the commands
COMMAND 1

ping forum.manjaro.org

OUTPUT 1

ping: forum.manjaro.org: Name or service not known

COMMAND 2

ip link

OUTPUT 2

 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 2: enp37s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
   link/ether 2c:f0:5d:84:66:46 brd ff:ff:ff:ff:ff:ff
 9: wlp18s0f0u3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
   link/ether 8e:c1:0c:f7:c2:43 brd ff:ff:ff:ff:ff:ff permaddr d0:37:45:f3:44:2a

COMMAND 3

rfkill

OUTPUT 3

     ID TYPE DEVICE      SOFT      HARD
     4 wlan phy4   unblocked unblocked

COMMAND 4

lsusb -v

OUTPUT 4

Bus 001 Device 012: ID 2357:0109 TP-Link TL-WN823N v2/v3 [Realtek RTL8192EU]
Couldn’t open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.10
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x2357 TP-Link
idProduct 0x0109 TL-WN823N v2/v3 [Realtek RTL8192EU]
bcdDevice 2.00
iManufacturer 1 Realtek
iProduct 2 802.11n NIC
iSerial 3 00e04c000001
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 0x0035
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 5
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 2
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x84 EP 4 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x05 EP 5 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x06 EP 6 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x87 EP 7 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 3
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x08 EP 8 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0

OK, try:

ip link set wlp18s0f0u3 up
ip link

and report.

when i type

ip link set wlp18s0f0u3 up

it says:

RTNETLINK answers: Operation not permitted

& when

ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp37s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
link/ether 2c:f0:5d:84:66:46 brd ff:ff:ff:ff:ff:ff
3: wlp18s0f0u3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
link/ether a6:5e:40:de:6d:dd brd ff:ff:ff:ff:ff:ff permaddr d0:37:45:f3:44:2a

Then try with sudo:

sudo ip link set wlp18s0f0u3 up

It gives nothing, no error, no message

This is just the setting command. Output would be expected after

ip link

I would like to know if it is still saying “state DOWN” or “state UP” for wlp18s0f0u3.

My bad :stuck_out_tongue:, Sorry I know its frustrating I am still new. here is the output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp37s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
link/ether 2c:f0:5d:84:66:46 brd ff:ff:ff:ff:ff:ff
3: wlp18s0f0u3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
link/ether 9a:7b:5b:f3:d1:b9 brd ff:ff:ff:ff:ff:ff permaddr d0:37:45:f3:44:2a

This seems to be a driver issue as I assumed already. In this case I would try to install the rtl8192eu driver.

sudo pacman -Syu linux59-headers dkms git base-devel --needed
cd
git clone https://github.com/Mange/rtl8192eu-linux-driver
cd rtl8192eu-linux-driver
sudo makepkg -si
echo "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu.conf
sudo mkinitcpio -P
depmod -a
sudo update-grub

Afterwards reboot.

I tried but it didn’t worked, also before this i have tried installing these drivers:

rtl8812au-dkms-git (AUR)
rtl88xxau-aircrack-dkms-git (AUR)