TP-LINK Archer T600U Plus

I am new to linux and I bought a TP-Link wifi adapter ( TP-LINK Archer T600U Plus ) and I have no idea where I can get the drivers. Archwiki didn’t help much. I thought u guys might have an idea about how can I make it work.

Hi!
Can you post the output of inxi -N

I am also fairly new to linux and I bought the TX50E as I saw that they had some linux drivers for some cards so I mistakenly assume that they had one for their newest models. Any help would be most appreciated. Or does anyone know of a Wi-fi 6 card that will work on linux?

After I installed the rtl8812au-dkms-git 5.6.4.2.r9.g49e98ff-1 driver, I get the following:

Did you manage to get this working?

As it can be seen from the screen shot, the Device-2, which is my TP-Link TX50E, is using the driver IWLWIFI which is the Intel driver that is the in Linux Kernel.

It seems that IWLWIFI driver should work for the Cyclone Peak 2 chipset and I have been told by TP-Link that the TX50E is based on that Cyclone Peak 2 chipset.

So, it does connect to the router (which is not wi-fi 6) but it is very slow and often drops the connection altogether.

So the short answer is, no, I did not manage to get this working properly. I might just put the TX50E in my next Windows computer build.

I’ve bought this card today. I’ve just plugged it in my motherboard and it’s working without any issues.
I have MAG B550 Tomahawk motherboard and 5.8.6-1-MANJARO kernel.
If there is anything I can do to help you, feel free to ask.

Here is the output of inxi -N:

Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
driver: r8169 
Device-3: Realtek RTL8125 2.5GbE driver: N/A 
Device-4: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152

Hi 5ar,

is your router also wi-fi 6? Mine is not, it is a 3 year old generic router.

I changed the computer’s OS to Windows 10 Pro and then I had the same problems as I had in Manjaro (very slow and drop-off completely) then in Windows Device Manager I disabled all settings in the Property “802.11 ax” (“ax” is the key here and I left all other 802.11 settings the same) in the Advance Tab and now it is working properly.

I wonder if something like needs to be done in Manjaro. My main computer has Manjaro OS so let me know if there are any settings like in Windows.