TP-Link Archer T3U Plus Driver

I recently installed Manjaro on my Main PC that has a USB TP-Link Archer T3U Plus WiFi card.
I can’t make it work.

What did you tried?
This too?

I have tried this, it doesn’t work.

Have you tried a different kernel? Are you dual-booting with Windows? If you are, you need to disable Windows fastboot as it will cause problems on the Linux side. Please post an inxi output.

Please read:

Yes, I am dual-booting and I have already disabled fastboot on the Windows Side.
this is the inxi output:

CPU: 6-Core AMD Ryzen 5 2600 (-MT MCP-) speed/min/max: 3586/1550/3900 MHz
Kernel: 5.11.22-2-MANJARO x86_64 Up: 13m Mem: 2101.3/16003.6 MiB (13.1%)
Storage: 3.87 TiB (7.8% used) Procs: 297 Shell: Bash inxi: 3.3.04

Please read the tutorial. A full inxi output is necessary to figure out what is going on, even if you do not think it is necessary. The tutorial explains how to post the full inxi in proper format.

Here you go:

  Kernel: 5.11.22-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=077c8b41-e15e-4897-9811-db47c72fce7b rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 amdgpu.ppfeaturemask=0xffffffff 
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <filter> 
  UEFI: American Megatrends v: P1.60 date: 11/05/2018 
  Message: No system battery data found. Is one present? 
  RAM: total: 15.63 GiB used: 2.51 GiB (16.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D cache: L2: 3 MiB 
  bogomips: 93453 
  Speed: 3419 MHz min/max: 1550/3900 MHz boost: enabled Core speeds (MHz): 
  1: 3419 2: 3700 3: 3733 4: 3879 5: 3539 6: 3697 7: 3580 8: 3851 9: 3690 
  10: 3789 11: 3812 12: 3442 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme 
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce 
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] vendor: Micro-Star MSI 
  driver: amdgpu v: kernel bus-ID: 25:00.0 chip-ID: 1002:687f class-ID: 0300 
  Device-2: Microsoft LifeCam HD-3000 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 3-4:2 chip-ID: 045e:0810 class-ID: 0102 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI-A-0 res: 1920x1080 hz: 75 dpi: 102 
  size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
  renderer: Radeon RX Vega (VEGA10 DRM 3.40.0 5.11.22-2-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 21.1.2 direct render: Yes 
  Device-1: AMD Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel 
  v: kernel bus-ID: 25:00.1 chip-ID: 1002:aaf8 class-ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus-ID: 27:00.3 chip-ID: 1022:1457 class-ID: 0403 
  Device-3: Microsoft LifeCam HD-3000 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 3-4:2 chip-ID: 045e:0810 class-ID: 0102 
  Sound Server-1: ALSA v: k5.11.22-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.28 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: f000 bus-ID: 1f:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp31s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: TP-Link 802.11ac NIC type: USB driver: N/A bus-ID: 1-4:4 
  chip-ID: 2357:0138 class-ID: 0000 serial: <filter> 
  WAN IP: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 1-3:3 chip-ID: 0bda:8771 class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 3.87 TiB used: 308.44 GiB (7.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: RKT303.3 temp: 31.9 C 
  scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000DM008-2DM166 
  size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC26 scheme: GPT 
  Optical-1: /dev/sr0 vendor: Optiarc model: DVD RW AD-5240S rev: 1.03 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r state: running 
  ID-1: / raw-size: 97.66 GiB size: 95.56 GiB (97.86%) used: 26.18 GiB (27.4%) 
  fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A 
  uuid: 077c8b41-e15e-4897-9811-db47c72fce7b 
  ID-2: /boot/efi raw-size: 99 MiB size: 95 MiB (95.96%) 
  used: 25.3 MiB (26.6%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 52DB-30D9 
  ID-3: /mnt/d39b15eb-80dc-4d14-af07-7e3c929e51a2 raw-size: 931.51 GiB 
  size: 915.82 GiB (98.31%) used: 282.24 GiB (30.8%) fs: ext4 dev: /dev/sda1 
  maj-min: 8:1 label: DATI uuid: d39b15eb-80dc-4d14-af07-7e3c929e51a2 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs label: Ripristino 
  uuid: 4894D8EF94D8E08C 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 140.19 GiB fs: ntfs label: N/A 
  uuid: F0A2DDCAA2DD9606 
  ID-4: /dev/sdb1 maj-min: 8:17 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-5: /dev/sdb2 maj-min: 8:18 size: 2.73 TiB fs: ntfs label: 3TB 
  uuid: A05E60365E6006FE 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0610 class-ID: 0900 
  Device-1: 1-3:3 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA chip-ID: 0bda:8771 
  class-ID: e001 serial: <filter> 
  Device-2: 1-4:4 info: TP-Link 802.11ac NIC type: WiFi driver: N/A 
  interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 500mA chip-ID: 2357:0138 
  class-ID: 0000 serial: <filter> 
  Device-3: 1-5:5 info: Cooler Master Masterkeys Lite L Combo RGB Keyboard 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
  speed: 1.5 Mb/s power: 100mA chip-ID: 2516:0042 class-ID: 0301 
  Device-4: 1-6:6 info: Logitech G502 SE HERO Gaming Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 046d:c08b class-ID: 0300 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 2-1:2 info: Genesys Logic USB3.1 Hub ports: 4 rev: 3.2 speed: 5 Gb/s 
  chip-ID: 05e3:0626 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-4:2 info: Microsoft LifeCam HD-3000 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  power: 500mA chip-ID: 045e:0810 class-ID: 0102 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 44.4 C mobo: 0 C gpu: amdgpu temp: 36.0 C 
  mem: 39.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 2683 
  Processes: 299 Uptime: 19m wakeups: 0 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1393 lib: 421 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.04```

5.11 Kernel is EOL. It would be a good idea to go with 5.10 LTS or 5.12 including the kernel headers.

Check to see if the adapter is blocked:
rfkill list

Check this post as it is a possible solution:

Hello azel04,
Welcome and have fun with Manjaro :blush: Recently we had a similar topic before, but I’ll write it here again in more detail. As far as I know, your wifi device has a RTL8812BU chipset from Realtek. In this case, the following driver from the AUR will work : rtl88x2bu-dkms-git by RinCat.
Don’t forget to install the appropriate kernel headers. For kernel 5.12 you can do this e.g. via the terminal with the command sudo pacman -S linux512-headers.
Then you can then install the PKGBUILD rtl88x2bu-dkms-git via Pamac, either using the GUI or the terminal. After that, restart the computer. In Pamac you have to make sure first, that AUR support is enabled in the preferences.

I have to do this command? I have the linux512-headers installed.

pamac build rtl88x2bu-dkms-git

Exactly. To make it easier, you could also search for rtl88x2bu-dkms-git via pamac GUI, after you activated the AUR in it. Both work equally well, of course. Basically it doesn’t matter if you use Pamac, yay, trizen or similar as AUR helper. The GUI of Pamac makes it easier for the beginner.

Thank you!
Boot up was slower tho. Is it normal?
SDDM and KDE took longer to load.

Depending on your hardware this can happen. For example, when the desktop already starts, but the WiFi connection is still being established. This should be solved by deleting files left over from building the driver, so-called orphans.

how do I do that?
can i use yay -Scc ?

If you want to use yay, the command yay -Yc should do the job to delete the orphans. You can also additionally delete the cache by using yay -Scc It is up to you.

It says it deletes this stuff:

               java-atk-wrapper-common-0.38.0-1  java-environment-common-3-3  jsoncpp-1.9.4-1
               libuv-1.41.0-1  meson-0.58.0-2  ninja-1.10.2-1  node-gyp-8.1.0-1  nodejs-16.2.0-1
               npm-7.15.0-1  python-beaker-1.11.0-6  python-coverage-5.5-1  python-mako-1.1.4-1
               python-markupsafe-2.0.1-1  python-mock-3.0.5-6  python-nose-1.3.7-10
               python-pbr-5.6.0-1  python-setuptools-scm-5.0.2-1  rhash-1.4.1-1  sdl_net-1.2.8-5
               sdl_sound-1.0.3-8  semver-7.3.5-2  smpeg-0.4.5-5  vulkan-headers-1:1.2.178-1

is it safe to proceed? i installed multiple AUR packages (like PCSX2 for example)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.