Touchscreen doesn't fully work with Rpi4 with Manjaro ARM OS

I recently installed Manjaro ARM OS Xfce on a Raspberry Pi4B.
To increase the user-friendliness, I tried to hook up the Official Touchscreen display 7" Rpi:

  • I finished the tutorial,
  • hooked up the ribbon and the 4 cables to 5V,GND ,SCL and SDA
  • powered up the whole system.

I get the boot screen with the buffer and the Manjaro logo and then I get a black screen with a blinking cursor.
The OS is straight out of the box the only configuration done is VNC server :

  1. ssh into RPi:

    ssh @
  2. install TigerVNC:

     sudo pacman -S tigervnc
  3. configure XDMCP by modifying /etc/lightdm/lightdm.conf

    sudo nano /etc/lightdm/lightdm.conf
  4. In the [LightDM] section:

    • uncomment and set start-default-seat=false
  5. In the [XDMCPServer] section:

    • uncomment and set enabled=true
    • uncomment port=177
  6. restart lightdm:

    sudo systemctl restart lightdm
  7. create /etc/systemd/system/tigervnc.socket:

    sudo nano /etc/systemd/system/tigervnc.socket
  8. paste the following text:

    Description=TigerVNC Server
  9. create /etc/systemd/system/tigervnc@.service

     sudo nano /etc/systemd/system/tigervnc@.service

10 . paste the following text:

  Description=TigerVNC Per-Connection Daemon

  ExecStart=-/usr/bin/Xvnc -inetd -query localhost -geometry 1440x900 -once-urityTypes=None
  1. systemctl to start and enable

    sudo systemctl start tigervnc.socket
    sudo systemctl enable tigervnc.socket
  2. reboot

    sudo reboot 

OS: Manjaro ARM Linux aarch64
Host: Raspberry Pi 4 Model B Rev 1.4
Kernel: 5.10.52-1-MANJARO-ARM

@Darksky I haven’t have a clue.

My setup isn’t using the jumper wires.

1 Like

I do not have that Display or use TigerVNC. Have you taken TigerVNC related configd out of the picture and tested to isolate where the issue might be.

I suggest leaving this set to true.


I’ve got that display but no vnc server.

But I’m not going to be home for a while.

I’ve followed the instructions but with minor edits to the configuration. and the last edit is form pi3 screen

Thank you, VNC and touchscreen works simultaneously. All I need know to is how to enable keyboard on lightdm (I did it from GUI, but it won’t work).

Do you mean you used the “Login Window” menu selection under Settings, to modify lightdm?
And by keyboard, do you want to enable the virtual keyboard in lightdm?

Or is lightdm is not responding to any keyboard input?

Yes, I meant I used the LightDM GTK+ Greeter Setting activate keyboard (onboard doesn’t work so I tried QVKbd keyboard but it’s way too small so I tried finding other one). Do you have any recommandation for a virtual keyboard.

Oh yes, the gtk+ greeter. Sorry, I keep forgetting about that. I use the slick greeter instead.

Sorry, I do not use the virtual keyboard, it is one of the settings I disable. I think the virtual keyboard is part of the greeter, you might try a different greeter and see if you get different results.

Oke, I will try it, thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.