Touchpad/mouse issue freezing system

Hi guys,
I have noticed lately that the cursor gets stuck sometimes and stops working for a second or two. However, today the whole system froze completely that even ctrl+alt+F2 wouldn’t work and a hard reset was necessary twice in 5 minutes. There were no updates or system changes. I don’t use the touchpad but the Kensington Trackball. Well, another hard reset while writing this post. I removed the trackball just in case it was caused by it. Any ideas? Thanks!

edit: I had cairo-dock installed but disabled it on boot because it was clashing with the bottom panel. However, the system still loaded it anyway. Uninstalled it completely and so far no freeze yet.

System freeze is usually rather a consequence of intensive CPU/RAM usage. Have you tried monitoring them?

Yes, I have got conky running but when it froze I had Opera browser opened and couldn’t see the process that hanged the system. I have got a 12 core and 16GB DDR4 so the RAM shouldn’t be an issue. It takes less than 2GB with Opera running. I killed the Cairo-dock, uninstalled it and the system was fine without the trackball. Just got it up and running and so far so good with the trackball. It seems even bang on set. I’d blame a graphics issue for this. I think it was only the screen that was frozen and not the whole system. Well, the trackball just hanged for a second but it used to do before as well. Another hang while writing this post. It a bit annoying but the system still works.:slight_smile:

Well, that was quick. Another freeze this morning right after boot. I also realized that it’s not only the mouse/cursor but a keyboard freezes too. Randomly for a second or two. Seems like a common issue on Manjaro and that’s why I never used XFce before. It was full of bugs and probably still is. Back to Gnome I guess.

As a Xfce user, i don’t know what you are talking about. :unamused:

Another bottleneck i can think of is the drive: if many files are to be read at the same time, it can “block” the processes waiting for them. I can even relate that performance varies with brands/models.

I tried Xfce years ago because Gnome 3.0 was absolutely awful. Live CD was so terrible that there was no way to install it and expect a smooth system. Obviously I had a bit insufficient hardware back then but I didn’t expect this kind of troubles on a fast brand new steel. I have had a more stable system on a single core processor with 2GB or RAM using Feisty Fawn than today with 12 cores and 16Gb of RAM.:DDD
BTW: I have a full HD resolution but look at this. I see only half of the reply button.

Two things you can check:

Fixed it as it wasn’t maximized. Somehow missed this setting completely. Thanks!!
Just installed the 5.14 kernel and so far so good. I’ll give it a couple of days.:slight_smile:
edit: Just updated the system without the 5.15 kernel but it holds just fine. I’d call it a solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.