Touchpad Lenovo non funziona

Salve, ho installato Manjaro gnome 21.2.4 e il touchpad non funziona.
Al momento sto usando un mouse usb

Chassis: laptop
Operating System: Manjaro Linux
Kernel: Linux 5.15.25-1-MANJARO
Architecture: x86-64
Hardware Vendor: Lenovo
Hardware Model: IdeaPad 5 15IIL05

Come dovrei risolvere?
Ho provato le soluzioni proposte nelle altre discussioni ma non ha funzionato nulla.


1 Like


Sorry i will continue in english. You might have to add pci=nocrs as kernel boot parameter inside /etc/default/grub to the GRUB_CMDLINE_LINUX_DEFAULT line … also, bios needs to have Load system defaults disabled in some cases …

Potresti spiegarmi la procedura?

grazie tante

Either from terminal:

pkexec gedit /etc/default/grub

or Edit the file as Root from Files

Look for the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"

or whatever is on your file and make it like this

GRUB_CMDLINE_LINUX_DEFAULT="quiet pci=nocrs udev.log_priority=3"

Save it and open up terminal again, and run:
sudo update-grub

Reboot the system. If that does not help you can remove the pci=nocrs and update-grub again. and look into BIOS (that i can’t explain) and look for options like Load system defaults and disable it.

if its a recent install im guessing you took the option of proprietary drivers? worked fine while installing but after no joy.Reinstall taking non proprietary drivers and will be fine. I tried everything after making the same mistake nothing worked except reinstall.

ok ci provo

No ho installato due volte l’open source :mask:

Ho provato tutto, niente da fare :coffin: