Touchpad Issues on KDE

Recently reinstalled Manjaro, this time with Dual Boot, which was kind of a pain but not a big deal. The real issue arose when I tried to make the touchpad work like it would ideally. I rolled back the the latest LTS kernel, downloaded libinput along with libinput-gestures and configured them, but I still could not make it work properly. The main issue at the moment is the lack of functionality in terms of consistency with how I use the touchpad, such as when I tap with two fingers, the right click menu does open, but when I instead press the touchpad, it doesn’t open? I just want to configure it like an average windows precision touchpad, how do I?

Touchpad settings are under Settings/Input Devices on KDE. Have you tried that?
I have several laptops with 5.4 LTS kernels and they all work like they suppose to. It also help if you display your system info (inxi - Fxz) settings.

I have yeah but the problem persists. Thanks for the command, output:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "ur_PK",
        LC_NAME = "ur_PK",
        LC_MONETARY = "bgn_PK.UTF-8",
        LC_PAPER = "ur_PK",
        LC_IDENTIFICATION = "ur_PK",
        LC_TELEPHONE = "ur_PK",
        LC_MEASUREMENT = "ur_PK",
        LC_TIME = "en_PK.UTF-8",
        LC_COLLATE = "en_GB.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LANG = "en_PK.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:    Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire E5-573G v: V3.72 serial: <filter> 
           Mobo: Acer model: ZORO_BH v: Type2 - A01 Board Version serial: <filter> UEFI: Insyde v: 1.37 date: 02/16/2016 
Battery:   ID-1: BAT1 charge: 19.6 Wh condition: 31.8/37.0 Wh (86%) model: SANYO AL15A32 status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17567 
           Speed: 798 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM108M [GeForce 940M] vendor: Acer Incorporated ALI driver: nvidia v: 450.66 bus ID: 04:00.0 
           Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 2-7:3 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia resolution: 1920x1080 
           OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.1.7 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.4.64-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 4000 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 4000 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb bus ID: 2-5:2 
Drives:    Local Storage: total: 596.17 GiB used: 10.07 GiB (1.7%) 
           ID-1: /dev/sda vendor: Toshiba model: MK6465GSX size: 596.17 GiB 
Partition: ID-1: / size: 141.53 GiB used: 10.07 GiB (7.1%) fs: ext4 dev: /dev/sda6 
Swap:      ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%) dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 62.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 178 Uptime: 7m Memory: 7.69 GiB used: 2.69 GiB (34.9%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1224 Shell: Bash v: 5.0.18 inxi: 3.1.05

Genuinely struggling over drivers right now. Which is superior, synaptics, libinput, or mtrack? Whichever it is how do I go about configuring them to work like a perfect precision touchpad?

Your problem appears to be related with delays. have you tried adjusting those in KDE systemsettings?

Clicking and pressing are two different events. Have configured both?

I’ve tried to adjust the stuff using the normal KDE system settings GUI, but that didn’t help. Do you mean some other method of changing the settings?

I have tried to, that I can say for sure

What exactly do you mean by “when I instead press the touchpad”? Do you mean pressing harder or pressing for longer?

It’s one of those precision touchpads. I’m drawing a comparison between tapping without actually pressing it to the point where it goes down and makes a click and pressing it to that point as a proper click.

So, left-click works as expected and right-click does nothing?

No no, one finger click (left) and two finger click (right) work as expected, but one finger tap and two finger tap don’t do the same.

Ok, you’ll have to write a config file. Please post the output of sudo libinput list-devices