Touchpad does not work on Legion 5

Hi, I just installed Manjaro GNOME on my Legion 5. For one boot I think the touchpad worked fine, and now no matter how many times I reboot its not working. Suspending the laptop also didnt help. Please help

My inixi:

System:    Host: john-legion Kernel: 5.10.61-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: GNOME 40.4 
           tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 82B1 v: Lenovo Legion 5 15ARH05H serial: <superuser required> Chassis: 
           type: 10 v: Lenovo Legion 5 15ARH05H serial: <superuser required> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required> UEFI: LENOVO v: FSCN14WW date: 08/26/2020 
Battery:   ID-1: BAT0 charge: 60.5 Wh (98.1%) condition: 61.7/60.0 Wh (102.9%) volts: 17.6 min: 15.4 model: SMP L19M4PC0 
           type: Li-poly serial: 4613 status: Charging cycles: 16 
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 rev: 1 cache: 
           L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92663 
           Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1390 3: 1397 4: 1387 5: 1397 
           6: 1388 7: 1397 8: 1387 9: 1397 10: 1396 11: 1397 12: 1471 13: 1575 14: 1643 15: 1397 16: 1387 
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Lenovo driver: nvidia v: 470.63.01 bus-ID: 01:00.0 
           chip-ID: 10de:2191 class-ID: 0300 
           Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 3-3:5 chip-ID: 174f:244c class-ID: 0e02 
           serial: 0001 
           Display: x11 server: 1.20.13 compositor: gnome-shell driver: loaded: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:     Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb 
           class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A 
           bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Device-4: GN Netcom Jabra EVOLVE Link MS type: USB driver: jabra,snd-usb-audio,usbhid bus-ID: 3-2:3 
           chip-ID: 0b0e:0305 class-ID: 0300 serial: 00004487139A08 
           Sound Server-1: ALSA v: k5.10.61-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 1000 
           bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 38:f3:ab:15:ae:22 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 1000 bus-ID: 04:00.0 chip-ID: 8086:2723 
           class-ID: 0280 
           IF: wlp4s0 state: down mac: 56:0b:22:ea:e7:e5 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 5-3:3 chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Drives:    Local Storage: total: 1.38 TiB used: 24.76 GiB (1.8%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GDHTNI-87A0B size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD 
           serial: NJ12N513411502B79 rev: 11020C00 temp: 34.9 C scheme: GPT 
           ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB speed: 6.0 Gb/s type: SSD 
           serial: 1919E20206DF rev: 023 scheme: GPT 
Partition: ID-1: / size: 881.71 GiB used: 24.76 GiB (2.8%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 292 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 34.35 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 49.5 C mobo: N/A gpu: nvidia temp: 44 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 365 Uptime: 19m wakeups: 1 Memory: 31.29 GiB used: 3.49 GiB (11.1%) Init: systemd v: 248 Compilers: 
           gcc: 11.1.0 clang: 12.0.1 Packages: 1321 pacman: 1314 snap: 7 Shell: Zsh v: 5.8 running-in: gnome-terminal 
           inxi: 3.3.06 

As you haven’t received many answers, I’ve reclassified your question to the Gnome section, but could you do me a favour and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.

An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

I’m not a Gnome user (KDE here) but on KDE I’d like to see a xinput list as well for touchpad issues…


1 Like

Tbh switching to one of the newest kernels worked out for me

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.