Touche global gestures are grayed out and says "used by GNOME"

I just installed Manjaro 21.3.1 (with gnome 42) on my laptop and 3 and 4 finger gestures don’t work.

I tried reinstalling Touchegg from the official repository as well as Touché (the UI app).
I also tried those command lines from the Touchegg repository :

$ sudo systemctl enable touchegg.service
$ sudo systemctl start touchegg

And the service is active and running :

● touchegg.service - Touchégg Daemon
     Loaded: loaded (/usr/lib/systemd/system/touchegg.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2022-07-03 12:42:52 CEST; 6min ago
   Main PID: 508 (touchegg)
      Tasks: 4 (limit: 9176)
     Memory: 13.8M
        CPU: 2.763s
     CGroup: /system.slice/touchegg.service
             └─508 /usr/bin/touchegg --daemon

I also verified if my track-pad could handle gestures.

Device:           MSFT0001:02 06CB:7F8F Touchpad
Kernel:           /dev/input/event7
Group:            6
Seat:             seat0, default
Size:             102x67mm
Capabilities:     pointer gesture

Finally, I tried to install x11 gestures from gnome extensions but still nothing.

Is there any way to solve this issue?
Thanks in advance.

(I also posted on stackoverflow)

touchegg, touche and gnome-shell-extension-x11gestures are all in the Manjaro community repo. There is no need to use the AUR or GNOME Extensions website.

Did you restart the Touchégg service and restart GNOME Shell after?

I reinstalled those 3 from the official community repo and restarted the laptop to be sure.
Just to be sure, to enable gnome-shell-extension-x11gestures, I need to do it in the extensions app? (as it was already downloaded from the gnome extensions website)

So now only the 3-finger swipe gestures are working, but I can’t customize anything in the touché software as it is still grayed out…
Do you have an idea why?

Yes. Make sure it’s listed under Built-In, not Manually Installed. Remove it if it’s still listed under the latter.

I’m not sure. Touché is currently broken on the unstable branch, so I checked in a virtual machine using the stable branch. The Swipe with 3 fingers options are unavailable as they’re used by GNOME, but the Swipe with 4 fingers options are available.

EDIT: Just checked on bare metal, same result as in the VM.

Okay I finally ungrayed the settings.
I went in /home/.confing/touchegg.conf and replaced all the

<action type="GNOME_SHELL"></action>


<action type="SHOW_DESKTOP">

And then I changed manually in the Touché GUI what I wanted.

Thanks for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.