Toshiba Mouse and keyboard aren't recognized by xorg

Hello, this starts when my laptop’s touchpad first out of nowhere just stopped working, even though a mouse did. I tried fixing it by following about a few manjaro forum questions and arch linux questions, but this made it worse. I believe I did something that got xorg to not recognize the whole of my keyboard, mouse, and touchpad. Trying to reverse what I did (which was moving the files from xorg.conf.d folder to /etc/X11/xorg.conf.d/, or the opposite? I don’t remember) gave me no results, reinstalling drivers gave no results and I’ve read more than 14 questions in linux mint, archlinux, and manjaro forums that didn’t yield any results. I currently can only access a tty by editing the grub boot parameters when the grub splash menu shows up. I also tried updating the kernel, but no results. Thank you very much in advance if you help me. My kernel currently is 5.9.11-3-MANJARO x86_64 bits. my dm is lightdm, and my laptop is a toshiba laptop.

Extra details, I deleted some partitions in my laptop before this happened by a lot of time, though I hugely doubt that this is the problem, as I had 7, and I finished with 2, one that has my ESP, and one with my manjaro installation.

Please run libinput debug-events and check if touchpad and keyboard events register.

They do, it says something like

event6    POINTER_MOTION +27.030s BTN_LEFT(272) pressed, seat count: 1

repeatedly, and changes for different events.

So when you move your finger on the touchpad, you see lots of “POINTER_MOTION” events appear, but the actual mouse pointer does not move on the screen?

Well, no, I’m trying this in a TTY. If I try to do anything in a graphical environment, it won’t work as I have no access to either the mouse pointer nor the keyboard, so I can’t issue any command, the only buttons that seem to be working are the fn+function keys

I see, does an external keyboard or mouse work? Can you post the output of libinput list-devices?

I figured the solution out, in my xorg.conf, I had something like

    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"

Section "ServerFlags"
    Option "AutoAddDevices" "false"

And when I removed those, my touchbad and keyboard started working. Thank you for trying to help, I deeply appreciate it, and I’m sorry for taking so much of your time only to have fixed it myself, have a great day, evening, afternoon, or night!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.