Toshiba Laptop fan is not Detected / Running

It’s my second week in manjaro and my laptop heats up more than windows in addition that the fans are not ever working.

I looked up the arch wiki and read about lm-sensors and ran sensors-detect and agreed to all prompts. However, when i run sensors I dont get any option showing my fan or its speed. The output of sensors:

Adapter: ACPI interface
in0:          12.08 V  

Adapter: ACPI interface
temp1:        +38.0°C  (crit = +125.0°C)

Adapter: ISA adapter
Package id 0:  +40.0°C  (high = +72.0°C, crit = +90.0°C)
Core 0:        +37.0°C  (high = +72.0°C, crit = +90.0°C)
Core 1:        +40.0°C  (high = +72.0°C, crit = +90.0°C

I tried to configure the fan-control file according to the wiki:

chip "coretemp-isa-*"
set fan1_div 4

However, when I type sensors -s after settings the chipset I get the following error:

Error: File /etc/sensors.d/fan-speed-control.conf, line 2: Unknown feature name
coretemp-isa-0000: No such subfeature known

I’m out of luck so far in manjaro everything is going smoothly except my slow wifi and the fan problem.

System Information ( inxi ) Results:

  Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=68a7b56a-51ff-488b-b590-03703f2a654a rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel, plank wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: TOSHIBA product: Satellite C50-A393 v: PSCG8V-03K00FAR 
  serial: <filter> 
  Mobo: Intel model: PT10F v: Type2 - Board Version serial: <filter> 
  UEFI: Insyde v: 1.40 date: 04/22/2014 
  ID-1: BAT0 charge: 40.7 Wh condition: 40.7/48.4 Wh (84%) volts: 12.3/10.8 
  model: TKBSS NS2P3SZMC4WR type: Li-ion serial: N/A status: Full 
  Info: Dual Core model: Intel Core i3-3110M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19167 
  Speed: 1198 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 1197 2: 1203 
  3: 1197 4: 1196 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Toshiba driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Display: x11 server: X.Org 1.20.10 driver: intel display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.2.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Toshiba 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.4.80-2-MANJARO 
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lite-On driver: ath9k v: kernel port: 2040 bus ID: 02:00.0 
  chip ID: 168c:0036 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 689.33 GiB used: 25.04 GiB (3.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 1102 scheme: GPT 
  ID-2: /dev/sdb vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 3M scheme: MBR 
  ID-1: / raw size: 80.91 GiB size: 79.13 GiB (97.81%) used: 25.01 GiB (31.6%) 
  fs: ext4 dev: /dev/sda5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 217 Uptime: 6m Memory: 7.65 GiB used: 1.33 GiB (17.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1195 lib: 349 
  flatpak: 0 Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.1.08

Anyone can help?