Torchlight II doesn't start

It’s supposedly Linux native but it doesn’t start. Running it though Proton does work.

Any of you encountered this issue and were able to fix it?

I’ve tried many of the fixes found by googling the issue, but none worked.

First find why it doesn’t start before fixing anything.
I would start steam from the terminal to have direct output when trying to launch the game, this way you could probably see the obvious error in the console output.

1 Like
GameAction [AppID 219850, ActionID 3] : LaunchApp changed task to SynchronizingCloud with ""
GameAction [AppID 219850, ActionID 3] : LaunchApp changed task to SiteLicenseSeatCheckout with ""
GameAction [AppID 219850, ActionID 3] : LaunchApp changed task to CreatingProcess with ""
GameAction [AppID 219850, ActionID 3] : LaunchApp waiting for user response to CreatingProcess ""
GameAction [AppID 219850, ActionID 3] : LaunchApp continues with user response "CreatingProcess"
Game update: AppID 219850 "", ProcID 542481, IP 0.0.0.0:0
ERROR: ld.so: object '/home/radu/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/radu/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/radu/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/radu/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Starting app 219850
>>> Adding process 542481 for game ID 219850
GameAction [AppID 219850, ActionID 3] : LaunchApp changed task to WaitingGameWindow with ""
>>> Adding process 542482 for game ID 219850
>>> Adding process 542483 for game ID 219850
ERROR: ld.so: object '/home/radu/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
GameAction [AppID 219850, ActionID 3] : LaunchApp changed task to Completed with ""
gamemodeauto: 
Game update: AppID 219850 "", ProcID 542483, IP 0.0.0.0:0
RecordSteamInterfaceCreation (PID 542483): SteamUser017 / User
RecordSteamInterfaceCreation (PID 542483): SteamFriends014 / Friends
RecordSteamInterfaceCreation (PID 542483): SteamUtils007 / Utils
RecordSteamInterfaceCreation (PID 542483): SteamMatchMaking009 / Matchmaking
RecordSteamInterfaceCreation (PID 542483): SteamMatchMakingServers002 / MatchmakingServers
RecordSteamInterfaceCreation (PID 542483): STEAMUSERSTATS_INTERFACE_VERSION011 / UserStats
RecordSteamInterfaceCreation (PID 542483): STEAMAPPS_INTERFACE_VERSION006 / Apps
RecordSteamInterfaceCreation (PID 542483): SteamNetworking005 / Networking
RecordSteamInterfaceCreation (PID 542483): STEAMREMOTESTORAGE_INTERFACE_VERSION012 / RemoteStorage
RecordSteamInterfaceCreation (PID 542483): STEAMSCREENSHOTS_INTERFACE_VERSION002 / Screenshots
RecordSteamInterfaceCreation (PID 542483): STEAMHTTP_INTERFACE_VERSION002 / HTTP
RecordSteamInterfaceCreation (PID 542483): STEAMUNIFIEDMESSAGES_INTERFACE_VERSION001 / UnifiedMessages
RecordSteamInterfaceCreation (PID 542483): STEAMCONTROLLER_INTERFACE_VERSION / Controller
RecordSteamInterfaceCreation (PID 542483): STEAMUGC_INTERFACE_VERSION002 / UGC
RecordSteamInterfaceCreation (PID 542483): STEAMAPPLIST_INTERFACE_VERSION001 / AppList
RecordSteamInterfaceCreation (PID 542483): STEAMMUSIC_INTERFACE_VERSION001 / Music
Setting breakpad minidump AppID = 219850
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198043332086 [API loaded no]
[11:32:29] Generic   WARNING Failed to set locate to UTF-8 locale.. trying to force it.
[11:32:29] Generic   ERROR UTF-8 Charset not available. Check your LANG, LC_CTYPE, or LC_ALL.
Game removed: AppID 219850 "", ProcID 542483 
Game 219850 created interface STEAMAPPLIST_INTERFACE_VERSION001 / AppList
Game 219850 created interface STEAMAPPS_INTERFACE_VERSION006 / Apps
Game 219850 created interface STEAMCONTROLLER_INTERFACE_VERSION / Controller
Game 219850 created interface STEAMHTTP_INTERFACE_VERSION002 / HTTP
Game 219850 created interface STEAMMUSIC_INTERFACE_VERSION001 / Music
Game 219850 created interface STEAMREMOTESTORAGE_INTERFACE_VERSION012 / RemoteStorage
Game 219850 created interface STEAMSCREENSHOTS_INTERFACE_VERSION002 / Screenshots
Game 219850 created interface STEAMUGC_INTERFACE_VERSION002 / UGC
Game 219850 created interface STEAMUNIFIEDMESSAGES_INTERFACE_VERSION001 / UnifiedMessages
Game 219850 created interface STEAMUSERSTATS_INTERFACE_VERSION011 / UserStats
Game 219850 created interface SteamFriends014 / Friends
Game 219850 created interface SteamMatchMaking009 / Matchmaking
Game 219850 created interface SteamMatchMakingServers002 / MatchmakingServers
Game 219850 created interface SteamNetworking005 / Networking
Game 219850 created interface SteamUser017 / User
Game 219850 created interface SteamUtils007 / Utils
Game 219850 method call count for IClientUser::GetSteamID : 1
Game 219850 method call count for IClientUtils::GetAppID : 17
Game 219850 method call count for IClientUtils::RecordSteamInterfaceCreation : 16
Uploaded AppInterfaceStats to Steam
Exiting app 219850
No cached sticky mapping in ActivateActionSet.

I can see a few errors, however I have no idea hot to go about fixing them.

I tried editing launch options to include LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command% but it made no difference.

The errors for LD_PRELOAD gameoverlayrenderer.so are normal.
I don’t see relevant issues. Maybe this

[11:32:29] Generic   WARNING Failed to set locate to UTF-8 locale.. trying to force it.
[11:32:29] Generic   ERROR UTF-8 Charset not available. Check your LANG, LC_CTYPE, or LC_ALL.

//EDIT: Check your system language settings maybe

Start the game without any startup parameters (I see you added gamemode).

Also what version of Steam do you use? steam-manjaro or steam-native?

//EDIT: lot of results from googling “Torchlight II linux no start”

I use LSI-Steam.

System Language is English. Format is UK.

I have them both installed and I never quite understood which is which and that the difference is between the two.

On my side, it works with steam command line:
LD_PRELOAD=/usr/lib64/libfreetype.so.6 %command%

I have an hybrid GPU (Intel+Nvidia 970M)
Give it a try.

For me this does not work.

Looks like it’s trying to load 32bit .so on 64bit OS.

Install en_US.UTF-8 language pack and try again.

steam-manjaro is just the manjaro pack for steam, steam-native forces steam to use system libraries instead of their own runtimes, I don’t use it because it causes problems.

Uninstall steam-native and try again if installing the above language pack doesn’t work.

1 Like

I installed the game just to see and I got a different error complaining about font defaults.
This fixed it.
I have steam-native not-installed and en_US-UTF-8 installed.

You don’t need it. Steam. Actually. Works. Fine.

1 Like

Don’t worry about that error it is normal to have it if you run a 64 bits OS.

I think you are trying to a load an i686 library on x86_64.

̶I̶ ̶w̶a̶s̶ ̶u̶n̶a̶b̶l̶e̶ ̶t̶o̶ ̶f̶i̶n̶d̶ ̶t̶h̶i̶s̶ ̶p̶a̶c̶k̶a̶g̶e̶.̶ ̶W̶h̶e̶r̶e̶ ̶d̶o̶ ̶I̶ ̶g̶e̶t̶ ̶i̶t̶ ̶f̶r̶o̶m̶?̶

I was able to do this by uncommenting en_US.UTF-8 UTF-8 in /etc/locale.gen and then running locale-gen.

After this the game launches just fine.

Thank you very much.

Perfect, you could have used the manjaro settings manager as well if you preferred a GUI.

There is another issue now.

The game fails to start with prime-run, but if it delete this command from the launch options it runs, but it does so on the Intel GPU, if I’m not mistaking.

So how do I run it with NVIDIA?

I mean, is there a performance problem you’re having?
You could try running it from lutris and tick 'Enable NVIDIA Prime render offload'

Well yeah, about half, if not less the framerate I’m getting when running it with Proton and NVIDIA.

Maybe it is expected. Some “Linux” games on Steam are just windows executables wrapped into a Wine package so you can have worst performance than on current Proton which has many optimization compared to old Wine.
Some games run better in Proton than the native Linux build too.
Not solving the issue but still possible regarding the performance.

So it doesn’t run… maybe try to… start Steam from terminal… rinse and repeat.

The launch option
LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libfontconfig.so.1

is the only way I can run it.