Tor Browser Showing Black Screen

So i just installed the tor browser and it finished setting up the packages and everything, then when it goes to run it shows a black screen as show below

1 Like

How did you install the tor browser? Using torbrowser-launcher 0.3.2-2 from the official repositories? or from somewhere else like the AUR?

1 Like

official and yes it’s 0.3.2-2

hmm, that is strange. It looks like this is the initial window that comes up the first time that let’s you either choose the default setup or customize your setup (based on the title bar on the window). I think I’d try to uninstall it along with the tor package and the tor browser settings and then re-install the torbrowser-launcher again. Basically that should be providing you with the option to select the default setup or to customize the tor settings for proxy settings used if your in a country that blocks traffic

this is what is supposed to be on that dialog box

What desktop environment are you running?

kde the latest version

Same here with GNOME…


1 Like

I wonder why Arch put it into their official repos. It is such a pain to support. I’d ask the pacakger: kpcyrd <>

had the same issue and found a fix in reddit i guess

edit or create 2 files


and add the following line in those 2 files

owner /{dev,run}/shm/org.mozilla.*.* rw, 

restart apparmor

sudo systemctl restart apparmor 

Well the torbrowser-launcher in the repos is just a “launcher” It basically downloads the latest version directly from the tor project, checks the signature and creates the icons for you in your DE.

Has directly installing via the method @antman mentioned above work?

thanks for the fix i remember seeing that post but i couldn’t find it

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.