Tor Browser does not start again

Hello and good evening,
for some reason the Tor Browser does not start again after successfully starting yesterday.

Instead, i get the following message.
Does anyone know why that happend?
I installed Firejail. Does that be the reason? I do not recall to have changed anything in tor browser.

Thanks for reading.

ov 30 18:55:15.760 [notice] Tor running on Linux with Libevent 2.1.12-stable, OpenSSL 1.1.1h, Zlib 1.2.11, Liblzma 5.2.5, and L
ibzstd 1.4.5.
Nov 30 18:55:15.761 [notice] Tor can’t help you if you use it wrong! Learn how to be safe at
Nov 30 18:55:15.762 [notice] Read configuration file “/etc/tor/torrc”.
Nov 30 18:55:15.767 [notice] Opening Socks listener on
Nov 30 18:55:15.767 [notice] Opened Socks listener on
Nov 30 18:55:15.768 [warn] Error setting groups to gid 43: “Operation not permitted”.
Nov 30 18:55:15.768 [warn] If you set the “User” option, you must start Tor as root.
Nov 30 18:55:15.768 [notice] Closing partially-constructed Socks listener on
Nov 30 18:55:15.768 [warn] Failed to parse/validate config: Problem with User value. See logs for details.
Nov 30 18:55:15.768 [err] Reading config failed–see warnings above.

How did you install/configure/use tor browser?

Hello cscs,

i installed it with the pamac manager (gui). I do not recall that i really configured anything.
Thats kind of the first time that i encounter this kind of error.

Since i am not sure if some other installation is causing this, i may will just reinstall the system.
I was installing firejail, but i am not sure if that would not let it start.

Thank you

p.s. i kind of came just recently back to linux and i may or may not done something that caused it. Not sure really.

I did reinstall my system and this error is still popping up.
I went into the configuration screen but there wasn’t anything for me to check. So i started it. After i quit the browser, i tried to start it again and then the error appears.
So strange.

Your log messages looks like as if you try to run tor. But the “Tor Browser” don’t need a system install of tor. Tor is build into the Tor Browser.

MMm… i do not get it. Now it works.
Anyway, i think my problem solved itself and i do not know how. But it works.

I read somewhere that if you have Firefox open it sometimes prefents tor to open. Can that be?

You know what, i think you are right.
What i was doing first, was to start tor browser by clicking the icon. That did not yield anything.
Then i try to start tor via command and sure enough i only used “tor”. I think that explains the error. Oh man. I need to read more about tor.

Hello again,
it seems that the package that you can install with pamac-manager isn’t really working.
I checked the script and it had some weird namings in it.
After i uninstalled it and installed the official tor browser package, everything works fine.

I found some helpful tips (since i am still a newbie myself), how to integrate it with the system.

./start-tor-browser.desktop --register-app

Things, i did not know myself. Still learning.
After that, tor works fine.

So this is just an update.

Thank you

Theres more than one … which is why I asked.

Also … it still seems you have confused the difference between managing TOR nodes (thats ‘tor’) and the secure browser that uses those protections by default (thats the ‘tor browser’).

Its worth noting too that, unlike virtually any other software management situation, TOR specifically discourages any ‘install’ besides going directly to their website, downloading the archive, and running from there.
(though the AUR package tor-browser mainly just automates this)

Yes, you are right. Oh man, i can not tell you how hard it is to understand the mechanics.
On windows (yeah) its pretty easy. I am kind of relearning everything. On and off on Linux. I hope i am finally settling.

Also yes, to me Tor was the browser.
Then i checked the script and it looked like turkish. I am not sure. Anyway, at least i was able to solve it.
Though, i need to read more about tor itself, the mechanics and how maybe one day, to setup a server.
No, i am not adding anything to the browser itself.

But i wonder. Is that package that you can download via the manager broken? Or did i need to do something else?
Like i said, that did not work for me. It started the first time, but not the second time.
Very puzzling.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.