Tor Browser display issues after recent Manjaro updates

I’m using Manjaro/KDE Plasma/Stable and I’ve had some issues with Tor Browser since the latest Manjaro updates which rolled out about a week ago.Also, I use the Tor Browser bundle downloaded directly from the Tor Project website rather than the one from the repos. It’s been working fine for years until just recently.

Problem 1: I use an addon called ‘The Dark Reader’ which converts all webpages into a dark theme. For some reason this addon no longer works. I’ve tried reinstalling the addon and even did a fresh install of TB but it doesn’t work still. And by the way, I’m not looking to discuss whether or not you should use addons with TB so please leave that out thanks :wink:

Problem 2: Github does not display correctly now. All the content is sparsely spread out all over the place and some things seem to be sized incorrectly. It’s a mess to look at. There seems to be a serious formatting issue. Again, I’ve tried a clean version of TB and it makes no difference. There may be other websites with the same issue but I haven’t noticed any so far.

Problem 3: I can’t get videos to play on Invidious instances. The player says “No compatible source was found for this media”.

So yeh, it seems there is some kind of problem with the visual rendering in TB since the latest system updates. If I roll back to a Timeshift backup from before these updates then these problems go away. I don’t know what could’ve caused it.

Any ideas? I hope to fix this soon as all the bright websites are killing my eyes @_@

Thanks!

Update 1: I tried installing TB from the repos and it still has the same problem so I can rule that out too.

Hey @forumperson ,
i can confirm problem1, problem2, problem3, too, but i am on xfce. Somewhere in the internet i found complains about not working proton mail website, either, but cannot recall that post any more. As far as i know the video issues refer to the missing h264 codec, as the website html5test dot com says is not installed. But i double-checked it is! All needed packages are installed and firefox is perfectly running h264 content.

My steps to reproduce were: installing manjaro from iso “manjaro-xfce-20.2.1-210103-linux59” in a virtual machine and after activating AUR and installing torbrowser/launcher bundle in the current version. None of your 3 problems ocured at all and the html5 test shows a working h264 capabillity. Further i updated the whole virtual system/kernel and suddenly all 3 problems appear. So i guess there must have been an update (definitely not the torbrowser bundle itself) which breaks it.
I really hope someone can clarify/investigate that. Maybe there has already a bug been filed… I don’t know, yet, as i am new to manjaro, but fell deeply in love :heart_eyes: with it.

I’m glad someone else was able to confirm these issues.

So what kernel was it working with for you? I’m on 5.10.15-1. I tried to roll back to 5.9 a few days ago and I think the system complained saying it would break some packages or something like that so I ended up not doing it. For now I’ve reverted back to my Timeshift backup from before the problem occured as it was just getting a bit much to deal with :confused:

Following are two quotes from the comment section at New Release: Tor Browser 10.0.10 | Tor Blog :

Anon (not verified) said:

February 10, 2021

Permalink

Browser isn’t working properly and doesn’t show regular sites’ certificates in Arch Linux. It’s a bug related to glibc.

glibc 2.33 (not verified) said:

February 13, 2021

Permalink

regular TBB doesn’t work properly with glibc 2.33. i had to switch to alpha to be able to watch videos. images were partially missing and e.g. github was displayed like Page Style > No Style. maybe you warn your users of an update to 2.33.
platform archlinux

Interesting. Thanks for that. So if it’s a bug with glibc then I suppose we’ll have to wait for Manjaro to update it. I’ll keep an eye on the updates section. Does anyone know if my system will update properly if I keep holding off updates until the next big round of them? Normally I just accept updates as they come in but this one is too much of a problem.

No, don’t do that. Manjaro is a rolling release distro. If you stick to stable branch, you will have to update every few months. So update as soon as possible because they are tested and patched for weeks and are necessary for Your system. Of you avoid updates and update after every 2-3 updates then your system might collape because of one BIG update. Issues like these are very rare and is worth it because of all the latest features.

Well I have all updates until the last big batch of them which I thought was around a week ago (Looks like the 19th here: Announcements - Manjaro Linux Forum). So if I leave it for another week or two you reckon that’ll be ok? I was gonna try updating again once the next load roll out which I’m guessing will be this week or next. It seems they arrive every week or two with the odd few little updates inbetween.

By the way, TB updated since my last post but it didn’t fix the issue. I’m hoping a Manjaro update fixes it.

Cheers.

No, actually. Trying to delay updates on a rolling release distro like manjaro kills all the fun. Yes, you “may” have some problems on a update. But delaying a update to fix a problem isn’t efficient. But try updating as soon as you can. Use timeshift before each update. Don’t worry, updates arrive every month or so. If you face a problem, come here and tell it to the team. But if you keep delaying updates, your system might break down after one HUGE update.

I hope you understood what i meant. :wink:

Yeh I think I get ya. I normally run updates as soon as they’re available so this is just a rare exception to that. I do use Timeshift and that’s exactly what I’ve done here - reverted back to the most recent working snapshot. If I just update and have things broken again, well then what’s the point in Timeshift… This is the exact situation I run Timeshift for.

I just can’t handle all these websites killing my eyes. I need that plugin to work! I suppose I’m taking a bit of a risk but I’ll keep trying new updates and then reverting back from them as necessary until things work properly again.

Also, I was just thinking, what if I left my computer turned off for a few months or more and then turned it on one day and ran updates… You’d think there’d be something about the way the updates are managed to deal with this situation :thinking:

Thanks for the advice anyway :slight_smile:

You can continue using manjaro without updating. (No one is going to force you like windows) But you just can’t install or update anything.(You can either update everything, or nothing) No need to keep your pc shut down for months!

Well, delay updates only when you face problems like these. You can keep using manjaro with an old timeshift snapshot but you can’t update or install any new packages! (But you can with snaps and flatpaks.)

Yeh I get that. I normally run all available updates. And I have noticed that I’m not able to install any new programs without also running all the available updates. I know I’m not forced to run updates, I’m just thinking that there’s probably something in place to deal with situations when people leave their computer off for a long time and come back months later with lots of updates to do. It’s not that I’m planning on doing that myself anytime soon.

I’ll wait until either TB or manjaro has some new updates and then I’ll try again and see how it goes. I can’t hold off forever eh :stuck_out_tongue:

Wow, this is getting vivid here!
Thx for all clarifications. @forumperson, what about trying tor alpha, as suggested in the post from @Chhkuot? i can verify it’s working. Btw. thank you for the hint on timeshift. This seems a legit practice for the prevention on updates braking the system/simple packages. The more i get used to manjaro, the more i love running it. Although this tor problem is affecting me as the first issue i am having with manjaro, this made me learn a lot about and value that distro. I stay tuned for updates on here.

Yeh I’ll give the alpha version a try if things aren’t working when the next Manjaro updates roll out. Thanks for the suggestion.

I’m pretty sure the Manjaro welcome screen you get after a fresh install tries to steer you towards settings up Time Machine doesn’t it? Or maybe it’s Mint that does that… Anyway, yes, it’s among the first things I do when I setup pretty much any distro! It’s saved me from a bad situation many times whether it’s my own fault or not.

I’m not sure this issue is Manjaro specific. But whatever you use, Linux, Mac, Windows… you’ll always have some breakages from time to time. Manjaro is definitely my favourite distro so far. It hits the sweet spot of nice features, up to date software and stability. Plus the Arch documentation is pretty amazing so we benefit from that too. The users on this forum are also very helpful. I couldn’t really ask for more :slight_smile:

1 Like