Зависание компьютера

Всем здравствуйте! Столкнулся с такой проблемой: компьютер случайным образом зависает, во время игр, при просмотре видео, в режиме простоя. Сложность в том, что в логах ничего записать не успевает. Зависает и на винде, и на линуксе. Есть у кого-нибудь идеи как можно найти причину зависаний?

Пожалуйста, опубликуйте результат следующих записей

inxi -Fxxxza --no-host
cat /etc/default/grub
mhwd -li
inxi -Fxxxza --no-host
System:
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=fb0adad1-8d4f-4077-ba1e-41c67a3b5ef7 rw 
  bootsplash.bootfile=bootsplash-themes/xfce/bootsplash apparmor=1 security=apparmor 
  resume=UUID=2048d7fa-efb5-4058-9a2b-6fa839d842f5 udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: Z77-A v: Rev X.0x serial: <filter> 
  BIOS: American Megatrends v: 0603 date: 07/12/2013 
CPU:
  Info: Quad Core model: Intel Core i7-3770K socket: LGA1155 bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L1 cache: 256 KiB L2 cache: 8 MiB L3 cache: 7.8 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 56181 
  Speed: 3870 MHz min/max: 1600/3900 MHz base/boost: 3522/3800 volts: 1.0 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 3870 2: 3789 3: 3811 4: 3786 5: 3874 6: 3811 
  7: 3787 8: 3735 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: ASUSTeK driver: nvidia v: 455.45.01 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:11c0 
  Display: server: X.Org 1.20.10 driver: nvidia display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 271x203mm (10.7x8.0") 
  s-diag: 339mm (13.3") 
  Monitor-1: DVI-I-0 res: 1024x768 hz: 60 
  OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK P8Z77-V LX 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Device-2: NVIDIA GK106 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0e0b 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
  vendor: D-Link System DFE-520TX driver: 8139too v: 0.9.28 modules: 8139cp port: c000 
  bus ID: 05:00.0 chip ID: 10ec:8139 
  IF: enp5s0 state: unknown speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: ppp0 state: unknown speed: N/A duplex: N/A mac: N/A 
Drives:
  Local Storage: total: 1.02 TiB used: 175.94 GiB (16.9%) 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDS120G2G0A-00JH30 
  family: WD Blue and Green SSDs size: 111.8 GiB block size: physical: 512 B 
  logical: 512 B sata: 3.2 speed: 6.0 Gb/s serial: <filter> rev: 0000 temp: 28 C 
  SMART: yes state: enabled health: PASSED on: 1y 96d 11h cycles: 214 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD110 family: P300 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B sata: 3.0 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A8R0 temp: 30 C 
  SMART: yes state: enabled health: PASSED on: 63d 12h cycles: 85 
Partition:
  ID-1: / raw size: 102.99 GiB size: 100.88 GiB (97.95%) used: 28.01 GiB (27.8%) 
  fs: ext4 block size: 4096 B dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 5 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 36 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 10% 
Info:
  Processes: 272 Uptime: 1h 28m wakeups: 0 Memory: 7.72 GiB used: 2.34 GiB (30.3%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: pacman: 1506 
  lib: 434 flatpak: 0 Shell: Bash (sudo) v: 5.1.0 running in: xfce4-terminal 
  inxi: 3.2.01
cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="bootsplash.bootfile=bootsplash-themes/xfce/bootsplash apparmor=1 security=apparmor resume=UUID=2048d7fa-efb5-4058-9a2b-6fa839d842f5 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
mhwd -li

Warning: No installed PCI configs!
Warning: No installed USB configs!

Может быть, проблема, например, в перегреве, если воспроизводится под разными ОС? Есть возможность следить за температурой?

Ваша прошивка довольно старая, вы проверяли, доступно ли обновление?

Тоже сперва думал, что перегрев, следил за температурой под нагрузкой - в пределах нормы. В режиме простоя температура процессора 28-30 градусов и видяхи 30-37 и так же бывает зависает.

Вздутых конденсаторов на материнке нет, блок питания исправен. При неисправном SSD были бы ошибки ввода/вывода, при неисправной оперативке он или не запускался бы или свапил, а такого тоже не происходит.

Интересно. Может быть, но мне кажется мало вероятно, что в биосе проблема. Обновлю и посмотрю на результат.

Сталкивался с такими зависаниями и на винде тоже на компе с использованием интегрированного в ЦП видеоядра. Отдал ПК в сервисный центр, обратной связи пока не получил. У меня сильное подозрение, что это была электрическая деградация компонентов (https://youtu.be/ExwP2j3mqCY?t=490)

Может у вас тоже видеокарта сбоит? Попробуйте найти:
journalctl | grep -i "gpu hang"
Нужность этого поиска состоит в том, что “всего лишь” зависание видекарты, приводящее к перезагрузке драйверов, зависанию компа, дампу ошибки записывается в журнал с приоритетом notice (5) или info (6), т.е. ошибка имеет приоритет далеко не error (3), даже не warning (4), в то время как KDE засерает уровень (4) своим спамом ошибок очень сильно, при этом работает без видимых недостаков.

А так же в:
journalctl -p3 -b-1
journalctl -p3 -b-2
journalctl -p3 -b-3

подсказок не получается найти?

Только что завис, сразу после перезагрузки заглянул в логи:

journalctl

– Journal begins at Wed 2020-12-16 04:14:06 +05, ends at Sun 2021-01-10 18:14:58 +05. –
янв 10 17:45:31 mydomain kernel: x86/cpu: VMX (outside TXT) disabled by BIOS
янв 10 17:45:31 mydomain kernel: ACPI BIOS Error (bug): Could not resolve symbol [_SB.PCI0.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20200925/psargs-330)
янв 10 17:45:31 mydomain kernel: ACPI Error: Aborting method _SB.PCI0.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
янв 10 17:45:31 mydomain kernel: ACPI BIOS Error (bug): Could not resolve symbol [_SB.PCI0.SAT0.SPT2._GTF.DSSP], AE_NOT_FOUND (20200925/psargs-330)
янв 10 17:45:31 mydomain kernel: ACPI Error: Aborting method _SB.PCI0.SAT0.SPT2._GTF due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
янв 10 17:45:31 mydomain kernel: ACPI BIOS Error (bug): Could not resolve symbol [_SB.PCI0.SAT0.SPT2._GTF.DSSP], AE_NOT_FOUND (20200925/psargs-330)
янв 10 17:45:31 mydomain kernel: ACPI Error: Aborting method _SB.PCI0.SAT0.SPT2._GTF due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
янв 10 17:45:31 mydomain kernel: ACPI BIOS Error (bug): Could not resolve symbol [_SB.PCI0.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20200925/psargs-330)
янв 10 17:45:31 mydomain kernel: ACPI Error: Aborting method _SB.PCI0.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
янв 10 17:45:31 mydomain kernel:
янв 10 17:45:52 mydomain pipewire[1282]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: Could not get PID of name ‘org.freedesktop.portal.Desktop’: no such name
янв 10 17:46:02 mydomain pppd[1675]: Cannot determine ethernet address for proxy ARP
янв 10 17:46:15 mydomain pulseaudio[924]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
янв 10 17:46:39 mydomain sudo[3559]: vasiliy : a password is required ; TTY=pts/0 ; PWD=/home/vasiliy ; USER=root ; COMMAND=/usr/bin/pacman --color auto -Sy
янв 10 17:55:11 mydomain sshd[29428]: error: kex_exchange_identification: read: Connection reset by peer
янв 10 17:55:18 mydomain dovecot[607]: imap-login: Error: Failed to initialize SSL server context: Can’t load SSL certificate (ssl_cert setting): The certificate is empty: user=<>, rip=74.120.14.39, lip=188.234.213.183, session=
янв 10 18:05:31 mydomain sshd[56780]: error: kex_exchange_identification: read: Connection reset by peer
янв 10 18:11:22 mydomain dovecot[607]: pop3-login: Error: Failed to initialize SSL server context: Can’t load SSL certificate (ssl_cert setting): The certificate is empty: user=<>, rip=192.241.223.211, lip=188.234.213.183, session=<xnKhhou43qXA8d/T>

Завис в 17:45:31 и ничего не записал, но похоже сообщение от ядра.

если сообщение от ядра, возможно стоит попробовать другие вёдра - воспроспроизводится ли на паре других, например, 5.9 и 5.4. Помимо доступны бета-версия ядра 5.11 в ветке обновлений unstable, но не уверен, что без должного опыта с переключением веток туда пока стоит лезть и это можно попробовать в случае, если с более устоявшимися ядрами всё равно наблюдается проблема.

У пациента давно уже такие симптомы. Не думаю, что проблема в самом ядре, с предыдущими версиями всё было также. Но ядро по сути обрабатывает все процессы в компьютере и возможно есть какие-то аппаратные проблемы, которые ядро не может нормально обработать и это вызывает зависание системы. Как будет возможность, отнесу в сервис, может там что-нибудь найдут, а пока буду поглядывать в логи, может появится хоть какая-нибудь подсказка. Понять бы хоть в каком направлении искать.

без должного опыта

Не сказал бы, что прям большой опыт, но далеко не новичок. Ещё с Кармического Медвежонка влюбился в линукс и начал активно его изучать. Через пару месяцев собрал Арч, ещё через год/полтора Gentoo, недавно жене купил новый комп, а её себе забрал, не захотел заморачиваться с установкой, Арч мне всегда больше всех нравился, а Manjaro на Арче основан, выбрал его. Просто обычно если что-то не работает, в логах появляются ошибки, по которым легко можно нагуглить решение, а тут вообще ничего, он просто застывает. Буду рад новым идеям и если смогу победить отпишусь.

PS: Мне, похоже, профессию пора менять на писателя =)

У меня таже фигня, без привязки к чему-либо виснет каждые несколько дней.
Пока что я 9 числа сбросил биос, заного настроил. Из чего-то особого у меня была в настройках общая частота ОЗУ 1600, при том 2 планки-то частотой 1600, а другие 2 1333, сейчас 1400 поставил. Вот 14 число уже, работает 24/7, не виснет, хотя это ещё маленький срок. К тому же раньше такой хрени не было, несколько месяцев назад началось, так что очень странно привязывать это к настройкам биоса, ну да пока так, послежу ещё. Проц в разгоне был до 4400, сейчас 4300 поставил на всякий случай, но это вряд ли он, не греется вовсе, по идее до 4500 должен безопасно работать.

Вспомнил, что бывали проблемы с xfce4-genmon-plugin, удалил, всё равно не пользуюсь, почти двое суток работает без зависонов, посмотрим как дальше будет.

UPD:
Зависать стал реже, но зависает. Раз в 2-ое суток примерно. Куда копать не представляю, надоело, сдаюсь =(

Проверьте тестом Memtest86+, он в меню граба есть внизу списка, сделайте несколько проходов, а лучше на ночь оставьте. Если хотя бы одна ошибка, то значит проблема в железе.
У меня так же недавно зависания начались, и даже на Винде синие экраны, в журнале пусто. Мемтест выдал кучу ошибок в первый же проход в тестах #7 и #8.
И в моём случае возможно дело не в памяти, т.к. по отдельности планки ошибок не дают. Виновником может оказаться и проц, и материнка (они у меня старые)

1 Like

Но дело, конечно, совсем не в этом, да)

Проц не грееется под полной долгой нагрузкой выше 70, если об этом, выставлены всего лмшь безопасные 44, когда можно и 45 спокойно.

Проверь температуру северного моста, пальцем радиатор потыкай, если сильно горячий, возможно в нём проблема (Если были случаи перезагрузки сетевой карты или звука, то скорее всего в нём и дело). Поищи вздутые конденсаторы рядом. Поставь дополнительный вентилятор. Откладывай чеканную монету на замену матплаты :wink:

нет ничего из этого
если посмотреть даже только по форуму манжары, то таких случаев куча, оказывается, где-то баг в софте это уже, видимо

Нагрев тут ни при чём. Точнее, вы выносите (или складывается впечатление, что выносите) неправильное суждение о том, что при разгоне на поведении компонентов может сказываться одна лишь (повышенная) температура, в то время как разгон – это (нерасчётный) вольтаж, и именно он определяет стабильность железяки. Нагрев уже во вторую очередь, если до него дело дойдёт. Так что сначала уберите разгон, и понаблюдайте недельку-другую, если у вас такие временные интервалы, на которых обязательно происходит сбой.
Вообще, вместо разгона куда безопаснее просто увеличить TDP, если так уж нужна повышенная производительность и система охлаждения позволяет.

Кстати. Ещё бывает так, что БП не может обеспечить достаточную мощность, вот и случаются такие ситуации. Опять же, это либо разгон виноват (что тут уже вряд ли), либо БП готовится отдать концы.

Проблема, похоже, решена простым xset -dpms. Ещё нужно подождать недельку, но обычно не проходило и суток как компьютер зависал, а сейчас аптайм 2 с половиной дня. Почему на винде такая же проблема не знаю и ставить её только ради выяснения не особо хочется, я её мягко говоря недолюбливаю =).