Как установить английский интерфейс с поддержкой кирилицы?

Не могу сделать английский интерфейс с поддержкой файлов на русском.

Решил некоторое время назад переустановить линух. До этого больше года всё с локалью нормально было: интерфейс английский, русские файлы видны. И при этом никаких танцев с бубном я не предпринимал.

Сейчас у меня получается сделать только два варианта:

  1. интерфейс частично на английском (консоль и памак на русском, может что ещё, но пока так), русские файлы видны везде.
  2. интерфейс на английском (правда в памак некоторые элементы на русском), русские файлы не видны в double commander и libreoffice (может ещё где, не проверял, да и программ у меня мало).

Настройки при первом варианте:

Summary

В Настройках:
locale:

English en_US.UTF-8 – Display Language - English
Русский ru_RU.UTF-8 – Formats - русский

Regional settings

Language: American English и русский
Formats: Region: россия - русский (ru_RU)

/etc/locale.conf

LANG=en_US.UTF-8
LANGUAGE=ru_RU.UTF-8
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8

/etc/locale.gen

en_US.UTF-8 UTF-8
ru_RU.UTF-8 UTF-8

консоль locale:

LANG=ru_RU.UTF-8
LC_CTYPE=“ru_RU.UTF-8”
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_COLLATE=“ru_RU.UTF-8”
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES=“ru_RU.UTF-8”
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
LC_ALL=

консоль “localectl”:

System Locale: LANG=en_US.UTF-8
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
VC Keymap: us
X11 Layout: us
X11 Model: pc105

консоль “locale -a”:

C
en_US.utf8
POSIX
ru_RU.utf8

Настройки при втором варианте:

Summary

В Настройках:
Locale:

English en_US.UTF-8 – Display Language & Formats

Regional settings

Language: American English и русский
Formats: Region: россия - русский (ru_RU)

/etc/locale.conf

LANG=en_US.UTF-8

/etc/locale.gen

en_US.UTF-8 UTF-8

консоль “locale”:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=ru_RU.UTF-8
LC_CTYPE=“ru_RU.UTF-8”
LC_NUMERIC=“ru_RU.UTF-8”
LC_TIME=“ru_RU.UTF-8”
LC_COLLATE=“ru_RU.UTF-8”
LC_MONETARY=“ru_RU.UTF-8”
LC_MESSAGES=“ru_RU.UTF-8”
LC_PAPER=“ru_RU.UTF-8”
LC_NAME=“ru_RU.UTF-8”
LC_ADDRESS=“ru_RU.UTF-8”
LC_TELEPHONE=“ru_RU.UTF-8”
LC_MEASUREMENT=“ru_RU.UTF-8”
LC_IDENTIFICATION=“ru_RU.UTF-8”
LC_ALL=

консоль “localectl”:

System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us
X11 Model: pc105

консоль “locale -a”:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
en_US.utf8

Ещё вариант попробовал:
[root tip] Troubleshooting locale errors

Summary

[root tip] Troubleshooting locale errors

/etc/locale.gen

en_US.UTF-8 UTF-8
ru_RU.UTF-8 UTF-8

сохраняем

“sudo locale-gen”

Generating locales...
  en_US.UTF-8... done
  ru_RU.UTF-8... done
Generation complete.

проверяем:
“locale -a”

C
en_US.utf8
POSIX
ru_RU.utf8

И всё вернулось к 1-му варианту - файлы на кирилице есть, но и в интерфейсе тоже русский

Вот ещё вариант попробовал:
Sublime Text 3 Error: Package Control Locale Issues
хотя сама прога ошибок не выдаёт

Summary

Sublime Text 3 Error: Package Control Locale Issues
предлагают:

localectl set-locale LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8

–не помогает.

Вот ещё нашёл в поиске, но я не понял как это для себя настроить…
trouble setting up locale

Summary

trouble setting up locale - Newbie Corner - Manjaro Linux Forum
Getting necessary locales:

sudo locale-gen en_US en_US.UTF-8 de_DE de_DE.UTF-8

Setting en_DE to use en_DE definitions:

sudo localedef -i de_DE -f UTF-8 en_DE.UTF-8

Note: this works for the German English Hybrid, adjust the commands to meet your needs.

Как победить в этой ситуации?

1 Like

If you want English, I suppose I can answer in English! :grin:

I have British English installed (nu Russian at all) but I can see Russian file names:

ls ~/Videos/С*
'/home/fab-user/Videos/Солярис [1972].mkv' 

My locale:

locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=en_IE.UTF-8
LC_TIME=en_IE.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=en_IE.UTF-8
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=en_IE.UTF-8
LC_NAME=en_IE.UTF-8
LC_ADDRESS=en_IE.UTF-8
LC_TELEPHONE=en_IE.UTF-8
LC_MEASUREMENT=en_IE.UTF-8
LC_IDENTIFICATION=en_IE.UTF-8
LC_ALL=

(I use Irish English for most as that has € symbols for money and stuff like that)

Cyrillic has been part of UNICODE for > 25 years now, so are you talking about files on an NTFS volume?

If yes, can you post your mount command for that partition?
If no, Я говорю плохо, я понимаю мало :stuck_out_tongue_winking_eye: Please explain what the exact issue is?
:thinking:

It’s automounted. I don’t know exact command)
But i’ve tried just now sudo mount /dev/sdb1 /mnt/333/ and it’s the same. Strange thing is that one program sees cyrillic (dolphin) and another doesn’t (double commander). And yes NTFS used.

cat /etc/fstab

пожалуйста?

UUID=67db5810-49ea-4553-992e-0495541d4578 / ext4 defaults,noatime 0 1
UUID=be73e35d-0780-429a-8bbe-81ecd5095cb2 /home ext4 defaults,noatime 0 2

:thinking:

So you’re indeed automounting and why you have problems. Please provide the output of:

mount | grep "^/dev/.d"

when the NTFS volume is mounted (through whatever means you mount it)

We’ll then ensure it’s put into the fstab with correct manual options (Russian Windows code page)

:innocent:

/dev/sda2 on / type ext4 (rw,noatime)
/dev/sda3 on /home type ext4 (rw,noatime)
/dev/sda4 on /run/media/user/medi type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

from this:

You should close all applications that are currently using the disk and then try the following commands:

sudo umount /dev/sda4 #if that gives an error: no worries: your disk wasn't mounted
sudo mkdir /media/mydisk
sudo mount -t ntfs-3g -o rw,inherit,default_permissions,allow_other,streams_interface=windows,windows_names,compression,norecover,hide_dot_files,hide_hid_files,big_writes,codepage=855 /dev/sda4 /media/mydisk

once we’re certain that works, we’ll transfer it into fstab (to circumvent errors during boot)

  • obviously, change mydisk to whatever you like (if it’s a disk containing videos, use videos if an archive disk, use archive etc.

Tests to perform:

  1. Are existing files in русский язык showing up correctly?
  2. can you create a file in русский язык?

Then report back and we’ll make this permanent in fstab.

:+1:

1 Like

nope. still the same. in dolphin everything ok, in double commander not.
I’ve disable automount, restarted and …

sudo mkdir /run/media/test   
sudo mount -t ntfs-3g -o rw,inherit,default_permissions,allow_other,streams_interface=windows,windows_names,compression,norecover,hide_dot_files,hide_hid_files,big_writes,codepage=855 /dev/sda4 /run/media/test

Try Midnight Commander as that’s been out for a while now and if that works too, it’s a bug in Double Commander (Still in Beta?) and you should let them know

pamac install mc

:sob:

:grinning:
if only it was one dc - libreoffice doesn’t see cyrillic files too.

Something else is going on then… What’s the output of locale? (you never gave that)

In LO Writer on my machine:

2020-10-17_17-12

:thinking:

Something else is going on then… I think so too)
(you never gave that) In first post in russian…

Summary

/etc/locale.conf

LANG=en_US.UTF-8

/etc/locale.gen

en_US.UTF-8 UTF-8

“locale”:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=ru_RU.UTF-8
LC_CTYPE=“ru_RU.UTF-8”
LC_NUMERIC=“ru_RU.UTF-8”
LC_TIME=“ru_RU.UTF-8”
LC_COLLATE=“ru_RU.UTF-8”
LC_MONETARY=“ru_RU.UTF-8”
LC_MESSAGES=“ru_RU.UTF-8”
LC_PAPER=“ru_RU.UTF-8”
LC_NAME=“ru_RU.UTF-8”
LC_ADDRESS=“ru_RU.UTF-8”
LC_TELEPHONE=“ru_RU.UTF-8”
LC_MEASUREMENT=“ru_RU.UTF-8”
LC_IDENTIFICATION=“ru_RU.UTF-8”
LC_ALL=

“localectl”:

System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us
X11 Model: pc105

“locale -a”:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
en_US.utf8

Плохо:

Попробуй:

sudo locage-gen

:scream:

If that’s not it, I’m all out of ideas, really…

:sob:

sudo locale-gen
Generating locales...
  en_US.UTF-8... done
Generation complete.

If I add ru_RU.UTF-8 UTF-8 to /etc/locale.gen than I get partly russian interface
and locale be:

Summary
LANG=ru_RU.UTF-8
LC_CTYPE=“ru_RU.UTF-8”
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_COLLATE=“ru_RU.UTF-8”
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES=“ru_RU.UTF-8”
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
LC_ALL=

Anyway thanks. You got more than me))

Ah better! Does it work now???

If not try these settings as it seems to work on my system:

I have British English as default language and Irish settings for the € and °C and … and I can see :ru: fine! (Maybe there is something that’s missing from :us: English…)

If even that doesn’t work, I’m calling in someone else…

With this settings dc & libreoffice sees cyrillic files but I have partly russian interface (some programs in russian - for example in console and pamac)

Summary

@eugen-b Summary:

  • part of the interface is in Russian and he can see files mounted on an NTFS volume in Russian (mounted with codepage=855 now.
    OR
  • English Interface, but some files in some programs (E.G. Dolphin is fine, but LibreOffice is not) he cannot see Russian files…

:upside_down_face:

On my system it just works with British English
(@whatisit Have you tried :uk: instead of :us: :question:)
Have you ever seen anything like this?

Libreoffice has its own setting for interface language.
Alt+F12 -> Language Settings -> Language -> User Inteface Language.
But you need to install libreoffice-fresh-ru to be able to get Russian UI.

All those things with LC_… I can’t solve myself. I love to get rid of German UI to be able to present screenshots in English, but I’m too lazy to resolve it.

In locale.conf remove all quotation marks “”

1 Like

Libreoffice (and double commander) doesn’t see cirillic files. I don’t have problem with eng interface in it.

locale.conf has no quotation marks “”:

LANG=en_US.UTF-8
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8

With this libreoffice (and dc) can see cyrillic files but I have some programs with russian interface (console, paman). I want interface to be in english and programs can see cyrillic files. And I can’t understand how to do it.