Tom Tom devices is not recognized - VirtualBox is not currently allowed to access USB devices

My first problem was
"VirtualBox is not currently allowed to access USB devices. You can change this by adding your user to the ‘vboxusers’ group. Please see the user manual for a more detailed explanation.
I solved with the Basic Host configuration
This failure is solved.

But still my TomTom navigation device is not recognized within the Virtualbox running Windows 7 or 8. Even though in my Manjaro Linux system under usb devices my TomTom device is shown as a USB device.

Does anybody have a clue why it is still cannot be connected within the virtual machine? Or is it that TomTom mydrive may not support the use of virtual machines anymore to better able to detect the owner of the device. At least more than 1 year ago everything worked well.

Is virtualbox-ext-oracle installed on the host?

In addition to that:
you have to configure one specific USB port or one specific USB device to be passed through to the VM

I don’t know the specific steps because I do not currently have VirtualBox installed or in use.
Can’t be more specific than that now.
But I do know there is an option for that in the VM settings - it may have to be set before the VM is started, may not be possible at run time, when the VM is already running.

As @Nachlese noted. It looks like this:


I have done it but it didn’t change anything.

Yes, I also have tried it out with USB 3.0 and also with USB 2.0 settings also with Windows 7 and Windows 8.1. With USB 2.0 an unknown devices is detected in the windows device manager but the driver software cannot be installed anywhere even mydrive is correctly installed.
The strange thing is it worked once in earlier times but not anymore after an obligational update of Tomtom mydrive software. It may be that tomtom does not want the people to use a virtual machine, because they cannot detect people this way. :face_with_raised_eyebrow: