Today's package conflict: package-query, pamac-common, pamac-snap-plugin, pamac-flatpak-plugin, yaourt. Can't update anymore, please help!

I have an issue with updates. I cannot update or install anything anymore because of this.

When trying to update I get the following error:
Kann Abhängigkeiten nicht erfüllen:
(Cannot resolve dependencies)

  • das Entfernen von package-query verletzt Abhängigkeit von ‘package-query>=1.8’ benötigt von yaourt,
    (removing package-query violates package-query needed by yaourt

  • wenn möglich, entferne yaourt und versuche es erneut
    (if possible remove yaourt and retry)

Removing yaourt doesn’t seem to make much sense, because this would lead to the whole system basically being uninstalled system by dependencies.

Also I had a look at the existing packages, and “libpamac” is not even installed on my system.

The transaction overview:

How can I fix this, please? :slight_smile:
Thank you!

OMG, pleaae do yourself a favour and uninstall yaourt !! It is deprecated since quite some time.

Or just use pamac.

1 Like

read last update announcement is always a good idea :wink:

1 Like


When I tried uninstalling yaourt first, the system threatened me it would remove hundreds of packages with it. That’s why I didn’t remove yaourt.

So I now tried ‘pamac update -a’ from the Update-Threat. It gave me the list of potential changes to be performed, but I did not yet commit changes. Instead I opened the graphical package manager again, and tried removing yaourt for checking which dependencies this would kill again. Strangely there where no further dependencies this time, so I removed yaourt. It seems as ‘pamac update -a’ had fixed the problem without me actually having commited the changes it announced!
After this the graphical update allowed me to update, and it’s running now, with 310 packages to go.
I will update you about the results!

  1. Systems wants to reboot now! See you! (I hope :slight_smile: )
  2. System is back again, now wants to install a new Kernel.
  3. OK, everything seems to be working. Also I can install packages again.

Thank you!
If only I had a clue what happened right now… :wink:

Well, it was yaourt which made a knot thicker and thicker to weird dependencies.

1 Like