TM6010 Capture card not working well

I have a MygicaU6813 card (id 1f4d:6650) which DOES have the Trident TM6010. When I plug It normally, It doesn’t do anything, but when I try to plug It in, It spams this v4l error:

libv4l2: error dequeuing buf: Resource temporarily unavailable

and also the image is struggled with a green color. So I tried to change the settings, but no success.

How can I have the video?


Have you checked this Trident - ArchWiki ?

This is not about my capture card, It’s about the video output cards.

My Mygica U6813 with Trident TM6010 chip is a capture card which haves a linux driver called TM6000. It seems the driver is a bit buggy, and I think It’s something related to the kernel, as the driver at least shows some image, but it’s a bit struggled:

This is qv4l2 with the device opened:

I guess It’s something related with the upper part of the video? The very upper part of the video, as you may see, It’s just fine, but below that it’s just the video with that green struggling. I’ve tried all options, with no success.

Also, something to note: the driver is only working because I made It work.
To do that, I started the tm6000 module with modprobe tm6000 and did echo <device-id> > /sys/bus/usb/drivers/tm6000/new_id (everything with sudo).

I guess It’s possible to make that work well?