Tip: ventoy won't boot anymore?

I had this issue:

Bios boot-menue to select ventoy … nothing happens anymore :frowning:

I downgraded ventoy to an old release from here:


see under “Assets” example ventoy-1.0.57-linux.tar.gz

Extract and run in terminal with USB-Stick present: Ventoy2Disk.sh -I /dev/your_device
Use blkid in terminal to identify your device

Copy an *.iso to it, run and see if it works.

If it is running ok you can upgrade to newest ventoy release from ventoy ( see above )

Extract again and run in terminal Ventoy2Disk.sh -u /dev/sda?

blkid in terminal tells you where the USB-pen is plugged in!

This way i have now again a working ventoy USB-pen.

Good luck an use carefully blkid to identify where the USB-pen is plugged in.

No idea, why this way it’s working!!

Is your device using UEFI or BIOS legacy?

Try to delete Ventoy partitions in the USB-stick before ISO backup.
Then open Ventoy2Disk GUI and click the button “Install” instead “update”, then check if it works?

It’s UEFI, i’m happy that it works again!

When using the GUI you can choose MBR or GPT under options / partition style. Since you are UEFI I’d choose GPT.

1 Like

I allways used a terminal and never the ventoy-GUI. Didn’t even know that it exists!

Your tip is the final solution: GPT Partition style and in my case secure boot disabled :slight_smile:

Hope others read this thread to the end, my workaround isn’t needed!

Thank you Locutus!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.