Timeshift the selected device does not have a linux partition

hello I am a noob ,
timeshift is not selecting my pendrive to store snapshots it says " selected device does not have a linux partition"
the file system of pendrive is fat32 according to gparted
please help me :sob:

Hi,

I’m not an advanced user, I’m more of that user who manages almost alone he he.

But I can tell you that the timeshift in manjaro works better with the BTRFS filesystem, however if you are trying to save your backups via Rsync mode, you can read it here with an online translator

Good luck!

T+ = See you later

1 Like

most pendrives are formatted that way
but, alas, fat32 indeed isn’t a linux filesystem
It doesn’t support permissions and file ownership - hence the message.
Linux can read it and write to it - but it is not a “Linux filesystem” because of the above.

simple solution: format the pendrive as ext4 filesystem :man_shrugging:
(the data that’s on it now will be lost, of course!)

4 Likes

this helped a lot thank you :innocent:

2 Likes

I did this and all worked thank you for helping me :innocent:

1 Like

One day I needed the forums a lot, as I still need it to this day, and everything I’ve been putting in my notepad that I kindly received from fellows around the world, I do the same out there in the same kind and pleasant way to try be useful to other fellows in using Linux.

For that and with that, I am very grateful for having helped you in some way.

T+ = See you later

2 Likes

The very clearly visible reference to the ext4 format when setting up Timeshift apparently was of no use. That could make teejee sad … :worried:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.