Timeshift problems

I’ve been running timeshift for some time now but a week ago I installed ssmtp to report on a new cron job. To my surprise I bagan getting timeshift errors, every hour on the hour. At the correct timeshift backup time I got the errors plus the timeshift action report. I’m still getting them.


(process:2251972): GLib-GIO-CRITICAL **: 11:00:01.743: g_file_get_path: assertion 'G_IS_FILE (file)' failed

** (process:2251972): CRITICAL **: 11:00:01.744: tee_jee_file_system_path_combine: assertion 'path1 != NULL' failed

** (process:2251972): CRITICAL **: 11:00:01.744: tee_jee_file_system_dir_exists: assertion 'dir_path != NULL' failed

/dev/sde1 is mounted at: /run/timeshift/backup, options: rw,relatime

Daily snapshots are enabled
Last daily snapshot is 15 hours old

I assume I’ve been getting these errors for the past gods-know how many months. Perhaps timeshift should have an email setup option, as luckyBackup does, that would perhaps auto-install a simple mail server such as ssmtp or sendEmail and make it clear that this was required.

Anyway, I found a recommendation on this (old) forum to edit the file /etc/sddm.conf and delete DefaultPath. I cannot find sddm.conf so this is not a solution. Help, please?

ALSO: On the Schedule tab of timeshift there is the message: “Snapshot device not selected”. This is either wrong or refers to something other than the device to which timeshift is daily backing up my system. Again, Help, please?

What happens if (as in my current instance) the original backup drive dies and the snapshots are assigned to a new one? Is the complete restore compromised or is there sufficient intormation in the later snapshots to restore correctly?

One other thing: there is no option I can find that allows me to change the daily backup time from 20:00 (when I am using the computer) to something like 03:00 (when I am not).

Can I assume no one knows the answers?

Can’t really comment on the errors, as AFAIK I’m not getting them.

But for :

“Snapshot device not selected”.

… on the ‘Location’ tab, one of the partitions has it’s radio button selected?


With regard to the backup time - there is no facility to change that - as this was against the ‘nearly zero configuration’ / AKA idiot-proof nature of Timeshift. So to do that, Tony said to take matters into your own hands, disable Timeshifts scheduling, and do your own cron task, etc.

Yes, a USB 3TB drive, to which the timeshift backups are successfully made. And in the Schedule section, just above “Snapshot device not selected”, I have Daily (5) selected.

do your own cron task, etc

Yes, a likely solution. I did modify the cron to add a debug but at the end of the run it re-wrote the cron line to remove it. Still, moving the cron to another file will probably fix that. :slight_smile:

I disabled Timeshift and added a line in another cron file to simulate the timeshift-hourly cron. I got…

(process:110720): GLib-GIO-CRITICAL **: 11:00:01.186: g_file_get_path: assertion 'G_IS_FILE (file)' failed

** (process:110720): CRITICAL **: 11:00:01.187: tee_jee_file_system_path_combine: assertion 'path1 != NULL' failed

** (process:110720): CRITICAL **: 11:00:01.187: tee_jee_file_system_dir_exists: assertion 'dir_path != NULL' failed

/dev/sde1 is mounted at: /run/timeshift/backup, options: rw,relatime

Scheduled snapshots are disabled - Nothing to do!

Basically, no significant change. And when I enabled Timeshift again it updated timeshift-hourly.

Can anyone answer my other queries, please?

hi… having the exact same issue (and even use ssmtp). do you ever solved it?
I tried the suggestion of installing the xhost package which was suggested here: GUI won't open (Manjaro) · Issue #190 · teejee2008/timeshift · GitHub (all issues related: Issues · teejee2008/timeshift · GitHub) but no success… (timeshift seems to work here just these annoying errors pop up). Nothing special in the timeshift log itself …

Never did. Sorry, but I’m glad I’m not the only one. :slight_smile:

I used to use luckyBackup - still do on the home folders; it’s a front-end gui to rsync but now has problems with backing up root and does not seem to be supported nowadays.

I still let TimeShift run as a possible backup, ignoring the accumulation of errors, but I’m not going to rely on it. I’ve set up rsync with cron to backup the root folders and will use that if I am unfortunate enough to require recovery.