Timeshift, Gparted and other root apps not following the dark mode

Hi,
I’ve tried a lot of things to get some apps running with admin rights that do not follow the KDE dark mode.

I did some obvious things:

  1. Change the Gnome/GTK option for apps appearance into Settings.
  2. Installed the QGnomePlatform package (which have replaced the qt5ct).

All that I’ve got was having Pamac and other apps like the firewall (gufw) on dark mode, but not Timeshift and Gparted (among some others).

Can anybody give me some help? Thanks.

Root applications by default have Breath2 theme. If you run any application with sudo (with some exceptions for KDE apps, there run as root is more complicated) you’ll see the same effect. You probably can change it if you run System Settings as root:

pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dbus-launch systemsettings5
3 Likes

Hi Tomek, it worked like a charm.
When I first jump on Manjaro, I’ve read the Community is very user friendly.
You’ve made my day! Thank you!


I set Breeze in the Application Style - then it follows the scheme and matches the colours of the desktop.

Here’s my ‘Gruv’ style:

And for ‘Layan’ style, but with ‘Application Style’ set for a different theme:

I didn’t run settings as root… now set back to ‘breeze’

What’s the problem?
I’m interested why you’d have Gparted installed for KDE - I suspect some mixing of desktops messing up stuff here, as we have KDE Partition manager and it’s a better option for KDE…

1 Like

I’d rather use gparted instead of KDE Partition Manager. But it’s just a personal choice.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.