Timeshift Folder disappearing after restart


This is the path…but in ‘run’ folder there is no ‘timeshift’ folder after restart…If I open timeshift once, the folder reappears. I want it to always be mounted or appear after reboot. Trying to use grub-btrfs with automatic update-grub.

That’s because everything under /run lives on a tmpfs, which is a virtual-memory-based filesystem. Its contents start off in RAM, but if needed they can be paged out to the swap partition/file.

That is correct, because Timeshift will then automatically create the mountpoint and mount the filesystem where the backups are stored.

There is no need to, given that it will auomatically mount the filesystem whenever it runs. But if you must, then simply add a record for the filesystem to /etc/fstab. See… :arrow_down:

man 8 mount
man 5 fstab

But ‘grub-btrfs.path’ in deactivated automatically as it cannot find the mount point I think & as a result automatic grub update when a snapshot is created isn’t going to work…is this the case? Or it will work automatically even if grub-btrfs.path seems to be turned off??

This I cannot tell you. I only use timeshift for making backups by way of rsync.

When all else fails, read the documentation. :stuck_out_tongue:

1 Like

Installed Manjaro today, selecting btrfs in the installer & the installation is working fine.
So now I am just trying 2 take advantage of btrfs. I think I need to mount timeshift somewhere else :thinking:

Btw thank you😃
& @Aragorn Use 5.10 LTS kernel now :crazy_face:

‘grub-btrfs.path’ is loaded but inactive after a reboot but when timeshift creates a snapshot ‘grub-btrfs.path’ becomes active automatically and updates grub, so timeshift backups directly show on grub menu.
My snapshots isn’t inside /.snapshots/
So I had to change the path where ‘grub-btrfs.path’ looks for new snapshots.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.