Timeshift error to restore snapshot on fully encrypted installation

This is for newbies like myself, I have not the expertise to write the many aspects of this that could go wrong. So, modify it as you think it can be right for your particular situation, I do not take responsability for the results.
I have Manjaro xfce fully encrypted with the GUI at installation time. After installing the updates, it didn’t work, so, I tried to go back to the latest snapshot. I booted with an .iso burned on an usb-stick, but timeshift give me an error “Boot device not selected”, pointing that the “/boot” option (on the timeshift gui) was pointed to “Keep on root device”, which was encrypted, and that apparently is not right (which is not correct).
So, I just runned timeshift from terminal, but didn’t find the right options…, here are the steps I followed:

  • burn a manjaro .iso installation file to an usb-stick, and boot with it.
  • double click on the “File System” icon on your desktop.
  • in the file manager window that oppened, go to the left panel, and double click on the encrypted volume where manjaro is installed
  • it will ask for your password, choose the “Remember password until you logout” option, write your encryption key, and press enter
  • go to menu, open “Terminal”, type the following command and hit enter:
    sudo timeshift --restore
  • if it asks for your password, write it and give it enter
  • a list of available snapshots will appear, chose the one you wish (I would go for the last, but…), write the correspondent number and hit enter.
  • a message will appear, saying “To restore with default options, press the ENTER key for all prompts!”, and “Press ENTER to continue”, hit enter
    (In my case, I have my SSD mounted as sda, so, the following instructions are for that situation…).
  • It will then ask for the root ("/") device, offering as default something like “/dev/dm-0”, which is right, so, hit enter, for the default option
  • It will then ask for the “/boot/efi” installation site, and again, the default (something like “/dev/sda1”) is right, so, hit enter again
  • it will ask if you want to “Re-install GRUB2 bootloader?”, write “y”, and choose the default place, which in my case is “/dev/sda”, so, press enter
  • you will get then the final advice (disclamer), write “y”, hit enter, and that is it.
    Finally, the options are:
    “/” goes in “/dev/dm-0”
    “/boot/efi”, in “/dev/sda1”
    and to “Re-install GRUB2 bootloader?”, you write “y”, and choose “/dev/sda”
    When timeshift ended, I just rebooted and everything worked fine…

OR it looks like you need to read this:

OR it looks like you need to read this:

Let me know if you need any help with either.


Fabby, thanks for your advice…; three things:
1.- I think I never wrote in my previous post, that I had’t properly backed-up my data files… (which I had).-
2.- It was just timeshift that was not working (and still isn’t, for some people, if you are intrested): what I did was to AVOID reinstalling; if available at the time, the info I provided would have being important for me (and I hope it can help other people).
3.- I am not an English native speaker, so, I could not say which the spelling and/or grammer mistakes are; sorry; just speaking English, French, Italian, Spanish and some other thing, keeps me without learning the writing of it all… And bullying me about my writing in English couldn’t work, not for you, nor for me, because I know my excuses; ¿which are yours?, I am curious. I suere I did my best; sorry if it is not at the level you would like it.
Have fun.

  • I can get into trouble in 10 languages but only out of trouble in 6; no Spanish is not one of them.
  • Yes, English spelling is hard, grammar is easy.
  • If you don’t want to convert this post into a tutorial that’s fine.
  • If you don’t want a cold System backup but want to continue using timeshift, that’s fine as well.