Timeshift backups not listed anymore after system update

Hello all,

just switched from Win11 to Manjaro. Everything is great.
Diligently made timeshift backups. All ran well.

Today, after the system update timeshift backup made (rsync). Ran through. File was also created, but not listed in GUI or shell.



It works fine on arch, so unless @Yochanan uses different timeshift PKGBUILD for manjaro I don’t see how this is (only) rsync’s problem.

it worked for me, just downgrade the package as it says there:

sudo pacman -U https://archive.archlinux.org/packages/r/rsync/rsync-3.2.3-4-x86_64.pkg.tar.zst

buen dia y suerte…

they just say it’s incompatibility problem


it worked 4 me too

¡un beso para ti! :kissing_heart:

I use the Manjaro package which is the same as the AUR package. I maintain both. Timeshift is still working fine for me and I still can’t figure out why it’s not for others.

Yeah, me neither. Random thought: only difference I see is I’m using different disk/partition on arch where timeshift works, but on manjaro I’m using /home for snapshots. :man_shrugging:

Then you are simply not up to date. The problem has long been recognized. Does this really have to be explained and linked again and again? This is so exhausting…

Oh really? And what is the problem?

Some incompatibility with the new version of rsync. Like many others, I have to keep mine one version behind.
My snapshots are going to a separate drive.

1 Like

So how do you explain that exact same version of timeshift with exact same version of rsync works fine for some people, like for me on arch?

Please read the posts for today’s update. I’m running out of strength for this terrible update today.

I can’t, like anybody else so far.

Voodoo magic, perhaps :thinking:

So am I.

You mean you’re using Timeshift to backup /home/ or you’ve pointed Timeshift to create backups there (don’t do that)? I use Timeshift as directed (system backups only) and Back In Time to backup /home/ and another partition.

Surely you jest. I use the Manjaro unstable branch and I’m the one that syncs Arch stable to Manjaro unstable. I have updates installed before anyone else does.

❯ pacman -Qi timeshift rsync | grep Version
Version         : 21.09.1-3
Version         : 3.2.4-1


EDIT: I’ve unmarked the solution as downgrading packages is not supported. It may be a temporary workaround, but I do not recommend it.

Your answer goes well with the previous answers from those seeking help.

Yes, it’s the only way on this laptop. That’s a non issue. Just throwing out possible differences.

Have you actually clarified among yourselves whether there is a discussion about btrfs or rsynch? The actual problem only affects rsynch.

Yes, I think that’s self evident.

Then I’ll dam how resistant you are to the current reported problems and better ask somewhere else.

1 Like

I did a backup with timeshift after the update and before i started messing with my system because i had audio/video problems because i had removed Pipewire a while ago as it was not working right for me back then, now Gnome 4.2 seems to be defaulting to Pipewire so had to remove pulse and re-install Pipewire, audio/video playback is now working again on Gnome 4.2, after that i did another timeshift backup and it’s working fine for me, so guess I’m lucky this time.