Tiger Lake Sound Issues - Headphones Inverted?

Hi folks,

I decided to give Manjaro another go in the hope that ongoing Tiger Lake soundcard issues have been resolved, but it appears not. This is an extremely frustrating problem because it stops me using Manjaro completely.

I still have not figured out how to get the sound working properly. If i play sound through my speaker without an external speaker connected to the headphone jack, the volume is quite low. If I connect ANY 3.5mm cable to the headphone jack, the internal speakers sound normal volume again, but of course no audio will play through the headphone jack.

If I set Auto Mute to ‘Enabled’ and connect the headphone jack, my headphone jack will mute and the volume plays through the speaker? It is supposed to be the opposite, so it seems my audio is somehow inverted. I am not sure how else to describe it.

I created another thread about this months ago and never found a resolution. The only real thing I can say for sure is that the sound muting is inverted when the headphone jack is in use. I have included a screenshot of my audio device setup and from this, it looks like the sound is combining the internal speakers and the headphones? I’d be forever grateful if you could help me solve this. Thank you!

System:
  Kernel: 5.17.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=337573e8-ca58-403f-bb59-149248f540c9 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: HKD-WXX v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: HKD-WXX-PCB-B1 v: M1010 serial: <superuser required>
    UEFI: HUAWEI v: 1.18 date: 12/29/2021
Battery:
  ID-1: BAT1 charge: 60.3 Wh (99.7%) condition: 60.5/59.7 Wh (101.4%)
    volts: 13.1 min: 11.6 model: SUNWODA HB5781P1EEW-31T type: Li-ion
    serial: <filter> status: full cycles: 21
Memory:
  RAM: total: 15.41 GiB used: 2.91 GiB (18.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: 11th Gen Intel Core i7-11370H bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 884 high: 1132 min/max: 400/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 674 2: 626 3: 1056 4: 951
    5: 1132 6: 698 7: 923 8: 1015 bogomips: 52856
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: QUANTA
    driver: i915 v: kernel ports: active: DP-3 off: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a49
    class-ID: 0300
  Device-2: Luxvisions Innotech USB Camera type: USB driver: uvcvideo
    bus-ID: 3-6:4 chip-ID: 30c9:0041 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.61x14.96")
    s-diag: 775mm (30.53")
  Monitor-1: DP-3 pos: primary model: Samsung LF27T850 serial: <filter>
    built: 2020 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: eDP-1 note: disabled model: TL142GDXP02-0 built: 2021
    res: 2560x1440 dpi: 213 gamma: 1.2 size: 300x200mm (11.81x7.87")
    diag: 361mm (14.2") ratio: 3:2 modes: 2520x1680
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.0.4
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: QUANTA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:6 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 12.75 GiB (2.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: 511BS0512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    type: SSD serial: <filter> rev: ECFO13.3 temp: 25.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 210.27 GiB size: 205.91 GiB (97.93%) used: 12.7 GiB (6.2%)
    fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A
    uuid: 337573e8-ca58-403f-bb59-149248f540c9
  ID-2: /boot/efi raw-size: 200 MiB size: 196 MiB (98.00%)
    used: 50.7 MiB (25.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM uuid: 862E-ABBE
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 246.95 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 512 MiB fs: vfat label: WINPE
    uuid: 2430-EF1C
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 18 GiB fs: ntfs label: Onekey
    uuid: CAE03321E0331365
  ID-5: /dev/nvme0n1p6 maj-min: 259:6 size: 1024 MiB fs: ntfs label: WinRE
    uuid: CA94352194351185
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 2-3:2 info: VIA Labs USB3.0 Hub ports: 4 rev: 3.1 speed: 5 Gb/s
    chip-ID: 2109:0817 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 3-2:2 info: VIA Labs USB2.0 Hub ports: 5 rev: 2.1 speed: 480 Mb/s
    chip-ID: 2109:2817 class-ID: 0900
  Hub-6: 3-2.4:5 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1a40:0101 class-ID: 0900
  Device-1: 3-2.4.1:8 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
  Device-2: 3-2.4.2:9 info: Microdia Redragon Mitra RGB Keyboard
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 400mA chip-ID: 0c45:5004 class-ID: 0301
  Device-3: 3-2.5:7 info: VIA Labs USB Billboard Device type: Billboard
    driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA
    chip-ID: 2109:8888 class-ID: 1100 serial: <filter>
  Device-4: 3-4:3 info: Shenzhen Goodix Fingerprint Device
    type: Communication,CDC-Data driver: N/A interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 27c6:5125 class-ID: 0a00
    serial: <filter>
  Device-5: 3-6:4 info: Luxvisions Innotech USB Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 30c9:0041 class-ID: fe01 serial: <filter>
  Device-6: 3-10:6 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-7: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 232 Uptime: 5m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1199 lib: 334
  flatpak: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.16

Look under /usr/share/pulseaudio/alsa-mixer/paths/

Notably the hdmi-output-0.conf and analog-output.conf files.

(Port “1” in your sound volume GUI might be output “0” in the .conf files.)

There might be a section to edit to make it behave properly for your computer.

It might require a lot of trial and error, and can’t say for sure what exact combination of changes might be needed. Just hoping to give you hints of where to look to troubleshoot.

1 Like

Thank you! You might well be on to something here. There’s quite a lot of conf files in there, but I did notice this which may, or may not be important. I can’t work out why my soundcard is seemingly combining the internal speakers and headphone jack as one connection.

Edit: I should add that the state.plugged = no part stays the same, even if I connect something to the port.

Those .conf files do not dynamically change. They are installed/updated from the package manager.

And in fact, the naming convention is convoluted and unclear.

Think of these .conf files as instructions of “what to do” and “how to behave”.


On another computer, I had to change the options under [Element Front] in the file analog-output-speaker.conf to get my tower’s front headphone/speaker jack to behave properly with speakers that are always connected in the back port.

I honestly think it’s strange that there’s no straight forwards method to do this in a GUI.

1 Like

Thanks. I sort of have a similar setup. I almost always have an external speaker plugged in to the headphone jack. This is what I’m trying to get working properly. I’ve looked again in the output-speaker.conf and there’s quite a lot of entries for Element. I have the following under [Element Front]. Maybe it’s the ‘merge’ part is my issue? I really don’t know still!

[Element Front] switch = mute volume = merge override-map.1 = all-front override-map.2 = front-left,front-right

Make a backup copy of the file first.

sudo cp -v /usr/share/pulseaudio/alsa-mixer/paths/nameoffile.conf ~/nameoffile.conf.bak

Then comment out the line in the original file:

#volume = merge

Then save and restart the pulseaudio service (making sure there’s nothing currently playing sound at the moment.)

systemctl --user restart pulseaudio

Then see if there’s any change in behavior. :person_shrugging:

1 Like

Thanks Winnie. I tried this and a number of other variations but I wasn’t able to resolve it :cry:

I decided to flash another distro and test it out and low and behold, the EXACT same problem exists. Windows works perfectly fine (I have a dual boot setup).

I installed Zorin so I suppose it would do no harm to post on their forum too.

I was a very happy user of Manjaro before I upgraded my laptop and of course, part of me wishes I hadn’t bothered now. It’s so disappointing that I cannot get this problem fixed.

I agree that this type of fiddling around just for something basic (working sound / speakers / headphones) shouldn’t be necessary to use your computer. :frowning:

It’s a bit too “engineer-y”, and you can tell that user-friendliness and praticality is not on the PulseAudio developers’ minds when they write up something like this.

It’s not intuitive, nor is it clear what they expect of the end-user to configure their audio devices.

Seriously, read it. It’s confusing for a typical end-user that just wants to use their computer…


I wish you luck in finding out how to get your speakers and audio jack to work with each other.

1 Like

Thank you for the reply.

I have since discovered that it appears to be a driver support issue with my model of laptop. It’s a Huawei Matebook 14s. I understand it has something to do with the Conexant audio hardware not being supported by the kernel. It is the exact same from some other distros I have tried (Zorin, Mint etc).

At the moment there doesn’t seem to be a fix for it. Very frustrating. I’m stuck with Windows 11 it seems :roll_eyes:

Thanks for the suggestions. I’ll have another read through some of the possible solutions here and see if any of them work. Cheers!