Thunderbolt input does not work unless I open windows first

Hi all,

I have dual boot manjaro installed along windows. I use two monitors. The second monitor is connected to a thunderbolt input. This input does not work in manjaro unless I open windows first and then do a restart to my computer. It’s as if the thunderbolt input is activated only once windows is opened but not when manjaro is first opened. Does anybody else have the same problem?

I have NUC11 intel computer, with windows 11 and manjaro XFCE (latest version). I am fairly new and so if there are other information I should be adding let me know.

I would appreciate any help! It’s a bit annoying to do open windows first and then manjaro.
Thank you!

I don’t know if it has any bearing here as I run no Windows system unless virtual.

Ensure you do a clean Windows shutdown - that means - inside Windows Disable Windows Fastboot and Hibernation.

Hey, thank you for your reply!

I disabled both, unfortunately it did not work.

The weird thing is, I have another thunderbolt input, that one works fine. I prefer to connect it to the one that doesn’t work though, because the one that works is in front of the pc, and it makes a mess with the cables. This is also true for some of the usb inputs as well I think. When I connect my camera to one of the usb ports the camera works and in other doesn’t work.

I can’t help but thinking this is some sort of power-management setting somewhere. So check and double-check your UEFI settings…or even some kind of power setting in Windows, or even Manjaro…:man_shrugging:

I tried looking for something, but can’t find anything. Unfortunately.


Found something! (Possibly)

According to this page:

Automatically connect any device

Users who just want to connect any device without any sort of manual work can create a udev rule as in 99-removable.rules:


ACTION=="add", SUBSYSTEM=="thunderbolt", ATTR{authorized}=="0", ATTR{authorized}="1"

I’m thinking the 0 and the 1 id’s at the respective {authorised} parts of the rule must be adjusted, and unfortunately I don’t know how to. Yet.

Nope. Apparently that’s for all devices. See here.

Thanks for the reply!

No such file existed in that directory (there was another file). I created the file and added the line it didn’t work though.

I tend to agree with you. It sounds like a power-management setting issue. I checked the bios as well, nothing seemed helpful (that I am aware of at least).

Pity. Sorry I can’t help you further.

I’m presuming you did restart seeing as you mentioned the BIOS.

Yes, I restarted many times.

This problem also happened in ubuntu actually. At work I started working with manjaro and I thought maybe changing to another linux distribution might solve the problem.

the idea seems right, maybe force it as you said:
echo 1 | Sudo tee/sys/bus/wmi/devices/86CCFD48-205E-4A77-9C48-2021CBEDE341/force_power

Forcing power

Many OEMs include a method that can be used to force the power of a Thunderbolt controller to an “On” state even if nothing is connected. If supported by your machine this will be exposed by the WMI bus with a sysfs attribute called “force_power”.

For example the intel-wmi-thunderbolt driver exposes this attribute in:


    To force the power to on, write 1 to this attribute file. To disable force power, write 0 to this attribute file.

Note: it’s currently not possible to query the force power state of a platform.

you could also use “sudo nano” and the command line to create the file and put 1 to force…I’m just rambling

Hey, thanks for the reply!

I tried that already. Couldn’t find any directory within devices folder which contains force_power related file. And there were many files within devices directory. I don’t know which one is actually related to the thunderbolt.