Thunderbird startet nicht mehr

Hallo zusammen.

Ich hoffe, ich bin hier richtig, weil ich nicht weiß, woher das Problem kommt. Ob das ein Problem von der Paketverwaltung ist oder ein tatsächlicher Bug in Thunderbird. Jedenfalls hatte ich das Problem schon mal mit Thunar. Wenn ich auf das Icon geklickt habe war das Fenster kurz da, dann verschwand es wieder, wenn ich im Fenster irgendwo geklickt habe. Das Problem lag vielleicht im Bug von Thunar. Das Problem wurde danach gelöst. 2 Wochen danach passiert dasselbe mit Thunderbird. Am Anfang öffnete es sich dann schließt es kurz danach. Momentan kommt sogar gar kein Fenster. Habe es jetzt mehrere Male deinstalliert und installiert. Problem ist immer noch da. Kann mir jemand weiterhelfen?

Das Problem hatte ich bisher weder mit Thunar noch mit Thunderbird. Starte mal thunderbird vom Terminal aus und kopier die Ausgabe hier her als Code formatiert (d.h. den </> Button benutzen oder drei ` über und unter die Ausgabe schreiben).

hey. Da bist du ja wieder :sweat_smile:

[calBackendLoader] Using Thunderbird's builtin libical backend

(thunderbird:3376): Gtk-WARNING **: 13:44:31.400: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:3376): Gtk-WARNING **: 13:44:31.400: Theme parsing error: <data>:1:77: Expected ')' in color definition
Bus-Zugriffsfehler (Speicherabzug geschrieben)

Hm die GTK-Warnungen sind nicht dramatisch die sollten nicht stören, das scheint das Problem zu sein:

Der deutet auf einen falschen Speicherzugriff hin (wikipedia). Ich habe nur sehr wenig und alte Themen dazu im Internet gefunden (z.B. https://forums.mageia.org/en/viewtopic.php?t=11360&p=66278 oder https://bbs.archlinux.org/viewtopic.php?id=236948).
Mir fallen noch folgende Sachen ein die du ausprobieren kannst:

  1. mit thunderbird --safe-mode ohne Erweiterungen starten, wenns funktioniert durch ausprobieren feststellen welche den Fehler verursacht.
  2. flashplugin deinstallieren (du hast es ja in diesem Thread installiert) und überprüfen ob es damit zusammenhängt
  3. Einen neuen Benutzer für Manjaro anlegen und überprüfen ob bei dem Thunderbird funktioniert, wenn ja deutet das auf einen Fehler in den Konfigurationsdateien hin.

Eine Analyse eines Memory Dumps habe ich so auch noch nicht gemacht. Ich weiß da gerade auch nicht weiter. Falls das Problem weiter besteht kannst du es noch versuchen im englischsprachigen Teil des Forums zu posten (und hierher zu verlinken) vielleicht kann dich da wer besser unterstützen. Zum Übersetzen ist diese Seite hilfreich: https://www.deepl.com/translator der Übersetzer funktioniert relativ gut und wird von einigen Forenmitgliedern (z.B. SGS ) regelmäßig verwendet.

Hallo knatschfisch,
probiere mal Thunderbird ohne jegliche Extension/Addons zu starten, ob der Fehler dann immer noch auftritt. Oder mit einem neuen, ganz frischen Profil.

viele Grüße gosia

Sorry, bin erst heute wieder am Rechner. Und jetzt auch nur für kurze Zeit
@firefightux

  1. Safe mode habe ich ausprobiert, bekomme die selbe Fehlermeldung
  2. flashplugin habe ich mit dem Befehl sudo pacman -R flashplugin versucht zu löschen. Hoffe das war der richtige Befehl. Terminal sagt: “Ziel nicht gefunden”. Aber beim Paketmanager wird mir folgenedes gesagt:
    In Konflikt stehende Dateien:
    flashplugin: /usr/bin/flash-player-properties existiert bereits im Dateisystem
    flashplugin: /usr/lib/mozilla/plugins/libflashplayer.so existiert bereits im Dateisystem
  3. Neues Konto habe ich hinzugefügt und habe mich dort eingeloggt. Startet nicht.

@gosia

  1. Ich meine, ich hätte keine Erweiterungen oder Ähnliches installiert. Ich hatte Thunderbird über den Paketmanager deinstalliert und wieder installiert ohne Erfolg.

weiß jemand noch was?

Gibt es die Dateien den?
Was sagt

pacman -Qo /usr/bin/flash-player-properties

und

pacman -Qo /usr/lib/mozilla/plugins/libflashplayer.so

Wenn die keinem gehören dann lösche die Dateien, bzw. kopiere sie irgendwo hin wo sie nicht stören. Die libflashplayer.so Datei muss aber auf jedem Fall aus dem Ordner raus.

Falls das auch nicht hilft, fange mit einem ganz neuen Profil an. Die Profile werden normalerweise in ~/.thunderbird gespeichert. Benne den Ordner um, damit Thunderbrid komplett neu anfängt. Lösche auch den Cache Ordner in ~/.cache/thunderbird

Es hat tatsächlich geklappt!!! Ich danke euch allen.

Ich musste nur die Datei löschen. Dann konnte Thunderbird wieder starten.

Ich habe aber trotzdem interessenhalber noch ein paar Fragen.

  1. Warum ist dieser Fehler eigentlich aufgetreten? Und mich mich wundert sowieso, dass Thunderbird den Flashplayer braucht. Wofür braucht er ihn überhaupt?
  2. Habe ich dadurch jetzt eine Einschränkung bei Thunderbird?
  3. Warum habe nur ich, bzw. einige wenige das Problem und die anderen nicht? Oder gibt es grundsätzlich Probleme, wenn Flashplayer und Thunderbird installiert sind? Vielleicht liegt es auch an den beinahe 10 Jahre alten Rechner;-)

Thuderbird ist eigentlich nur ein Firefox der ein bisschen anders aussieht und noch einen IMAP, POP und SMTP Client intrigiert hat. /usr/lib/mozilla/plugins/ ist ein Standard Ordner für NPAPI basierte Plugins. Jedes Programm das NPAPI verwendet schaut da rein und lädt alles was da drin ist.

Angreifer können über Flash in Mails deinen Computer nicht mehr übernehmen.

Die Frage ist eigentlich warum ist ein Flash Plugin im Standard Ordner und das Paket flashplugin ist gar nicht installiert. Wie ist die Datei da hin gekommen? War das Absicht, ein Fehler mit pacman oder einfach ein Weg um Software mit Sicherheitslücken auf dein System zu bringen? Wenn das Paket nicht installiert ist bekommst du auch keine Updates. Das bedeutet, dass dieses Plugin veraltet ist und unzählig Sicherheitslücken hat.
Flash ist natürlich Grundsätzlich veraltet und hat Sicherheitslücken, egal ob das Plugin aktuell ist oder nicht.

Dann hat Thunderbird nun nichts mit Flashplayer zu tun. So wie ich das jetzt verstanden habe. Hätte mich auch gewundert. Ich bin mir nicht mehr ganz sicher, aber ich hatte über die Paketverwaltung mal den Flashplayer installiert, weil ich gewisse Anwendung im Netz nicht benutzen konnte. Aber ich habe jetzt im Terminal nicht sonderlich rum gefuchtelt. Ich gehe da eher dran, wenn es nötig ist. Wie jetzt zum Beispiel.

Ich hatte das Problem letztens mit Kdenlive. Mir hat es geholfen, folgende Zeile im Terminal auszuführen:
sudo pacman-mirrors -f5 && sudo pacman -Syyuu
Vielleicht wird dadurch auch das Problem mit Thunderbird behoben.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark