Thunderbird: More than one e-mail or attachment cannot be saved

I have a problem with Thunderbird.
From time to time I have to save a lot of emails for the documentation of projects in a certain directory.
Now comes the problem.
When I select an email it works, the save dialogue opens and I can save the file.
If I select more than one file, however, the open dialogue opens and I cannot save. I have always done this individually for a few files, but now I have several thousand e-mails and it is too much work for me.
The same error also occurs when I want to open more than one attachment at the same time. Something is going wrong.
It happens with all email accounts and also in safe mode in Thunderbird.

I would appreciate help, but I can’t find a solution to my problem in the search.

Thunderbird 78.8.1
Manjaro KDE 5.21.3

Hi @zulu666 :wink:

As I know, it is a limitation of most mail clients that you can only download one mail at a time. The only way to save hundreds of mails to disk is to run them as batch…

I remember this addons can do this:

This one worked quite good for me.

For newer versions of thunderbird, this should work:

But never used this one.

Hope that helps :wink:

Hi @megavolt

thank you for your help!
The problem is not a prohibition to save multiple files, but that instead of the save dialogue the open dialogue appears.
Also with the Import Export Tool.

An e-mail => Save as => Save file dialogue

1 e-mail => Save as => Open file dialogue
1 E-Mail: (Speichern=save)

2 E-Mails: (Öffnen=open)


HAHA…now i understand.

If you choose multiple mails, then you need to choose the folder, where these mails should be saved, but you can’t choose your own filename. It extract the subject, sender and date and use it as filename.

If you choose only one mail, then you can edit the filename and save.

I guess the open-diaolog is a bit confusing. :smiley:

Would you like to name the *.eml files yourself?

Edit: Just tried myself. I could export over 1000 mails without problems.

Exactly as you say it should work, but for me the open button is without function. Even if I select a directory and press “open”, nothing happens.
Do you also use KDE?

No, but shouldn’t be a difference, since it uses everywhere GTK and not QT. I use DWM at the moment on my laptop. At home I use Gnome3, switched from XFCE. Never used KDE seriously.

That is strange… So on my side it works without problems… Maybe you selected to many mails a once? I could imagine that it will struggle with 100.000 mails at once…

With one mail it works, even with only 2 mails it stopped working.

Maybe try to repair the folder?

I also try to repair the folder, doesn’t work.
I took another laptop with manjaro gnome, add the IMAP E-Mail, sync and could export it without any problems.
It seems there is a problem:
a) with KDE and Thunderbird
b) with my installation of Manjaro KDE and Thunderbird

It is because of my system. I installed Manjaro KDE again as a second system, connected Thunderbird to the email account and…
I can export more than one email.
Somewhere in the years something must have adjusted negatively with my system. Will probably set up the alternative installation times completely and then work with it.