Thunderbird links opening in Firefox instead of default browser

I trying to figure out how to make Brave as default Browser in Thunderbird. …Brave is set as default in the xfce setting. however in Thunderbird all link open in Firefox if I have it beside Brave.

and also I notices that the opt out button in Firefox setting is set to default and don’t give me the option to deselect it.

Firefox: 84.0.1-0.1
brave: 1:1.18.77-1
Thunderbird: 78.6.0-1

also any option in brave to speed up the mouse whee scrolling like Firefox in the about:config menu?

lovely greats

Open a terminal window and run these two commands (one after the other):

xdg-mime default brave-browser.desktop x-scheme-handler/http


xdg-mime default brave-browser.desktop x-scheme-handler/https

Hopefully this will set Brave as the default handler for opening links in your system.


thanks very much this is working

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.