Thunderbird is supposed to start on the left screen

Hello again

Thunderbird is supposed to start on the left screen, but that doesn’t work. I set the left screen as the main screen and put TB in autostart. I also end the session with TB on the left screen. Nevertheless, TB opens again on the right screen after a restart.
What can I do about that?

Does XFCE have such a feature? I doubt that. It always open windows on the main monitor. There is a reason why scripts like that exists: GitHub - calandoa/movescreen: Linux script to move windows across screens

However KDE and Gnome save the position on a second screen, as I know.

Thanks for the link. But I lack specialist knowledge. What exactly would I have to do?

My thought: create a text file called “” and save the script line in it. Then copy the text file to the path /usr/local/bin. Then run chmod a+rx /usr/local/bin/ Would that be okay?

That is exactly how it would be done. Then you add shortcuts as described. It grab the window in focus and move to the left/right screen.

There is no specialist knowledge required. The instructions are on calandoa/movescreen (scroll down).

Copy the downloaded script to your path in /usr/local/bin or to ~/.local/bin under your user profile if you don’t want to deal with path permissions (the local path will take precedence).

Make the script executable with chmod u+x ~/.local/bin/


Now, give @megavolt a little tick (under his post). Cheers.

1 Like

Hi @Tut_tut,

I have never used, nor am I interested in using Xfce, Gnome, Deepin…well, I think you get the idea. With KDE, I use Window rules to always have application windows open at predefined places.

Since I don’t use it, I don’t know if Xfce has something similar, but I found this that looks promising. Specifically the answer:

After having been pointed to the keyword “tiling”, and doing a quick search, I found a thread that pointed in the right direction:

“Did you look under Settings > Window Manager Tweaks > Accessibility (tab) > [tick] Automatically tile windows…” … well, almost…

  • Settings
  • Window Manager Tweaks
  • Placement (tab)
  • Minimum size of windows to trigger smart placement > move slider to the left!
  • Success!!!

I have never touched this menu so far, but the machine that annoyed me has a bigger monitor, so maybe the size used in the menu is relative to the screen size…

Hope this helps!

Great and thank you very much! I was able to use settings - fine tuning window management - focus - to solve the problem. I didn’t need an additional script.

1 Like

Wait… You need to start Thunderbird on the left of your screen, but not on your left screen (second monitor)?

On the second screen! When I place the mouse there, TB opens on this screen!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.