Thunderbird 91.1.0 does not save default settings

There is a bug on Thunderbird mail to 91.1.0. The default for mp3 is set on VLC media player. When I try to play a voice mail (mp3 format), you get a pop up message.

“What should Thunderbird do with this file?”

You get the pop up box every time you try to play a voice mail, even after you check the box to “Do this automatically for files like this from now on. Should I report this as a Thunderbird or KDE bug?

Thunderbird 91.1.0

Have you tried setting this directly in Thunderbird’s settings?

Yes, I’ve already done that, and that didn’t fix it. It’s a Thunderbird bug I believe.

I don’t have many ideas but creating a new profile and filing a bug at Mozilla.

How did you install version 91.1.0?

I wanted to try and figure it out from a fresh profile, but realized that only 78.14.0 is in the official repositories.

What if you rename the file handlers.json to force Thunderbird to create a new one?

mv  ~/.thunderbird/profile.default/handlers.json ~/.thunderbird/profile.default/handlers.json.bak

Replace “profile.default” with your actual profile directory name.

Then launch Thunderbird and try from scratch.

Refresh your mirrors.

1 Like

Looks like I’m on version 91 now! Interesting, since this is a recent Manjaro installation, yet forcing the mirrors to refresh was needed for the Thunderbird update to show up.

@fhins I tried again with Thunderbird 91, and renaming / deleting handlers.json does in fact reset the the “Open With” settings to the defaults. You can try to reconfigure it from that point forwards, in case there was an errant setting in the handlers.json file.

The update was through the default system. I never install or update anything unless it’s the official repository. It’s not that big of a deal but it’s just pain!

Did this fix it for you?
“mv ~/.thunderbird/profile.default/handlers.json ~/.thunderbird/profile.default/handlers.json.bak”

It was never broken for me in the first place, but I noticed by renaming the file, it reset the “Open With” to the defaults.

So my hunch is if there’s an errant string/option in your current handlers.json file, forcing it to generate a new one from scratch might solve your issue.

No such directory it says:
mv: cannot stat ‘/home/fhins/.thunderbird/profile.default/handlers.json’: No such file or directory


Try again?

Isn’t my profile name is what shows up in the Konsole? I tried both user name and profile name which is fred@Man-fh, and neither worked. I get the same error message.

Your Thunderbird (or Firefox) profile is different from your system user entirely. Simply browse ~/.thunderbird to see which profile is your default one.

I get this:
bash: /home/fred/.thunderbird: Is a directory
So what is the profile name?

You can view the contents of a directory with the “ls” command.

So for example,

ls ~/.thunderbird

will list the contents in your Linux user’s “.thunderbird” folder. (The “dot” in front means it’s a hidden folder.)

You will see the assigned directory name for your Thunderbird profile folder. It might look something like: tyhddwx25.default

It’s unique for each installation / user / profile.

I found the profile name, but for some reason can’t find the directory. I’m not going to worry about for now, as this is not a big deal. I’ll just wait for an update.
At the very least I learned a few things, and thanks for all your help!

Now that you know the unique profile folder name, you can replace it in the “mv” command, which will essentially rename the handlers.json file and force Thunderbird to create a new, fresh one (possibly without the bug you’re experiencing.)

So instead of this (using “profile.default” as an example)…

mv ~/.thunderbird/profile.default/handlers.json ~/.thunderbird/profile.default/handlers.json.bak

…do something like this

mv ~/.thunderbird/tyhddwx25.default/handlers.json ~/.thunderbird/tyhddwx25.default/handlers.json.bak

Keep in mind, the tyhddwx25.default is just an example. Use the one that exists in your .thunderbird folder.