Thunar unresponsive when copying to USB

Hello,

When I copy to or from USB sticks or my mobile phone that’s connected via USB, Thunar becomes unresponsive. I can’t open files anymore or browse through my hard drive. Copying is also very slow, but when it’s finished, everything is normal again.
However, I can use the computer normally (like internet browsing) while copying.

I found some older information about it from 2013 to around 2017. I think most user complained that the whole computer becomes unresponsive, so I’m not certain if it’s still the same issue. However, I ran these commands but sadly, it didn’t help and Thunar is still unusable as long as I copy files to USB.

Also the speed drops often to 50KB/s or less and it takes many hours to copy just a few Gigabytes.

echo madvise | sudo tee /sys/kernel/mm/transparent_hugepage/enabled
madvise
sudo echo $((1610241024)) | sudo tee /proc/sys/vm/dirty_background_bytes
16777216
sudo echo $((1610241024)) | sudo tee /proc/sys/vm/dirty_bytes
16777216

System: Kernel: 5.10.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.14.3 Distro: Manjaro Linux
Machine: Type: Desktop System: Intel product: KBL-R MRD v: 0.1 serial:
Mobo: Intel model: MIR1 v: RVP7 serial: UEFI [Legacy]: American Megatrends v: 5.12 date: 07/12/2018
Battery: Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270 charge: 100% (should be ignored)
status: Discharging
CPU: Info: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33615
Speed: 800 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics: Device-1: Intel UHD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.20.10 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.3 direct render: Yes
Audio: Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Device-2: C-Media USB Advanced Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3:2
Sound Server: ALSA v: k5.10.0-1-MANJARO
Network: Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0
IF: wlp1s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: e000 bus ID: 02:00.0
IF: enp2s0 state: down mac:
Drives: Local Storage: total: 942.70 GiB used: 687.83 GiB (73.0%)
ID-1: /dev/sda vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB
ID-2: /dev/sdb vendor: SanDisk model: SD8SN8U512G1027 size: 476.94 GiB
Partition: ID-1: / size: 19.10 GiB used: 13.90 GiB (72.8%) fs: ext4 dev: /dev/sdb6
ID-2: /home size: 400.62 GiB used: 292.15 GiB (72.9%) fs: ext4 dev: /dev/sdb7
Sensors: System Temperatures: cpu: 60.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 303 Uptime: 1h 11m Memory: 15.43 GiB used: 3.11 GiB (20.2%) Init: systemd Compilers: gcc: 10.2.0
clang: 11.0.0 Packages: 1589 Shell: Bash v: 5.0.18 inxi: 3.1.08

1 Like

same happens with me, so while copying I use pcmanfm. I still use thunar because I find it’s UI better than others.

1 Like

I tried it and it works perfectly! I thought it’s a kernel issue, but it seems that Thunar is the issue? Let’s hope it will be fixed eventually…

There is a lot to like with Thunar but I don’t recognize the unresponsiveness.

My use case is not the usual though which makes me speculate in the Xfce integration with gfvs - which Thunar makes use of to mount removable and network devices.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.