Thunar unable to mount internal encrypted SATA drive

works well with external encrypted USB drive though.
mounts well with manual commands.
when try using pcmanfm, get error: Not authorized to perform operation.
downgraded kernel to recommended, but no effect.
what more can try?

thanks in advance to anyone willing to take time to nudge me in the right direction :]

command inxi -Fazy outputs system info:

Kernel: 4.19.175-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64
root=UUID=83f557f9-6c88-4788-8ae7-181baae24849 rw
cryptdevice=UUID=54e12bc2-c250-46d7-bfda-b5841c5f68eb:crypt quiet
Desktop: Openbox 3.6.1 info: tint2 dm: N/A Distro: Manjaro Linux

Local Storage: total: 1.46 TiB used: 154.2 GiB (10.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: NE-256 size: 238.47 GiB block size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: rev: T1106A0 scheme: MBR
ID-2: /dev/sda maj-min: 8:0 type: USB model: TO Exter nal USB 3.0
size: 298.09 GiB block size: physical: 4096 B logical: 512 B
serial: rev: 0204 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM003-1SB10C
size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 7200 rpm serial: rev: CC43 scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Lexar model: USB Flash Drive
size: 28.91 GiB block size: physical: 512 B logical: 512 B rotation: SSD
serial: rev: 1100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?

Mount commands is a superuser command and usually restricted.

I don’t know much on mounting encrypted devices - you could try using a mount unit and a complementary automount unit.

Another option could be adding yourself to the storage system group.

This will make the system mount using root only asking passphrase on access

thanks, but did not work :disappointed:

but i dont understand how i can mount all external drives, encrypted or not, and everything works fine, but with the internal disk it dont want work …

This is because the device announces itself as either internal or removable - and removable devices are handled differently by udev.

One example - you can play with - if possible.

If you have an USB enclosure which you can equip with a random disk - you will probably be able to mount the disk inside it without root permissions - but if you take out the disk and attach it directly to the system using the systemboard’s disk controller you will need root permissions to mount the exact same device.

It can also be illustrated by using the command for listing disk devices - please look close at the colum RM - this is how the system know if the device is removable.

➜  ~ lsblk -la
sda         8:0    0 465,8G  0 disk 
sda1        8:1    0 465,8G  0 part /var/opt/mssql
sdb         8:16   0 476,9G  0 disk 
sdb1        8:17   0   400G  0 part /data/private
sdb2        8:18   0  76,9G  0 part /data/iso
sdc         8:32   0 447,1G  0 disk 
sdc1        8:33   0 447,1G  0 part /data/projects
sdd         8:48   1  59,6G  0 disk 
sdd1        8:49   1     1M  0 part 
sdd2        8:50   1    50M  0 part 
sdd3        8:51   1  59,6G  0 part /run/media/fh/0DCA-88AF
sr0        11:0    1  1024M  0 rom  
nvme0n1   259:0    0 476,9G  0 disk 
nvme0n1p1 259:1    0   512M  0 part /boot/efi
nvme0n1p3 259:2    0   100G  0 part /
nvme0n1p4 259:3    0   360G  0 part /data/build
nvme0n1p5 259:4    0  15,4G  0 part [SWAP]

I see … so this is normal in Linux? and i should look into options for ‘mounting without password as regular user’?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.