Thunar doesn't show fstab entries, only thunar root


#1

I’ve been using manjaro kde for about a year. Now i have new laptop with not so great hardware.
KDE is running nice, but i wanted to try xfce.

Now the first thing i’m doing after manjaro installation in kde was, add my nfs shares in fstab.
I have a text file with my fstab entries and i just copied and paste it to fstab. In kde that work great, and my drives appears immideatly on dolphin.

I’ve tried the same thing in thunar on xfce. I’ve use thunar root for this.
It works but my drive only appears in thunar root, not in thunar.

How to solve this?


#2

…ugh ‘root thunar’ still exists ?
Really shouldnt use GUI things in ‘root’ or ‘sudo’ mode at all.

As to the fstab things…
Well, whats everything look like?
cat /etc/fstab
sudo blkid


#3

Moved from #general-discussion to #newbies as this is a request for help, not a discussion item.


#5
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=5405-C135                            /boot/efi      vfat    defaults,noatime 0 2
UUID=29db5527-bc55-42c5-97d6-959ef0b6e17b /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
192.168.0.17:/volume1/video /home/hrvoje/synology_video nfs user   0 0 
192.168.0.17:/volume1/private_video /home/hrvoje/synology_private_video nfs user   0 0
192.168.0.17:/volume1/music /home/hrvoje/synology_music nfs user   0 0 
192.168.0.17:/volume1/homes /home/hrvoje/synology_homes nfs user   0 0
/dev/sda1: LABEL="ESP" UUID="5405-C135" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="383975bb-d733-423e-ad0a-06b0ec34aeec"
/dev/sda3: LABEL="Acer" UUID="E2DC080ADC07D825" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e065730d-05a0-4355-a28f-83feaca897f7"
/dev/sda4: LABEL="Recovery" UUID="84F608D1F608C600" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e06bf089-0d25-4100-aae6-8803b12fda84"
/dev/sda5: UUID="29db5527-bc55-42c5-97d6-959ef0b6e17b" TYPE="ext4" PARTUUID="2df1ea3c-1a99-404e-979c-e9d1d98bf923"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="ca36c0fb-982a-415a-aa77-70f8b21ccd7c"

#6

Look here:
https://wiki.archlinux.org/index.php/Thunar#Showing_partitions_defined_in_fstab


#7

Thanks. Adding “x-gvfs-show” on my lines in fstab solved the problem


#8

You should also remove the discard option from the / load line in fstab. Once you have disabled discard, you should enable the fstrim.timer. Discard is no longer recommended for SSD’s.