Thumbnails for video and image files on desktop stopped being generated

Until a few days ago, icons for any image or video file (and even PDF file) that I put on desktop would show as little thumbnail images made from the contents of that specific file. Since a few days ago, after one regular shut down and when I started computer again, these thumbnails are not shown when system loads. Instead a generic icon for video file or image file is shown.

I can force thumbnails to get generated if I right click anywhere on the desktop, select desktop settings, go to Icons tab, and then from Appearance - Icon Type select temporarily “Minimized application icons” and then switch back to “File / launcher icons”. With this, the thumbnails are generated quickly… but after the next system restart the issue re-appears again.

I tried to solve this by deleting everything from these folders


(I left the folders “large” and “normal”, just deleted the contents of these folders). The first time I restarted the computer, it took WAY more time for the desktop wallpaper to appear than usual, and the icons were generated as expected. I thought maybe it needed more time to generate all thumbnails for the first time, and that from then on things will be much faster… but I was wrong.

Now every time I restart the computer it takes several minutes for the desktop wallpaper and icons to show (and again it’s not showing the proper thumbnails, just generic icons), which is way longer than about 20 seconds it took before I deleted the thumbnails from .cache.

Is there a way to fix this issue with thumbnails not showing up properly on desktop? Or at least how can I avoid the excessive waiting for the desktop wallpaper and icons to appear? It can take up to 2-3 minutes to show up now. Something is obviously wrong.

Hi @Antarmanu71,

It seems that you are using XFCE.

In that case, thumbnails are generated by a package called tumbler: xfce:tumbler:available_plugins [Xfce Docs]. You can get information about this package using pamac info tumbler.

It may also be useful if you check your system for errors or failed services: System maintenance - ArchWiki


Hi @vcottineau,

Yes, I use XFCE manjaro, I forgot to say that in the previous message.
This is what I get when I execute info tumbler in my terminal:

I will see if some errors are reported or failed services are found by following the instructions on that page. Failed systemd services didn’t report anything.

I think I messed something up by deleting those files in .cache/thumbnails, although I’ve read that in general all files in .cache folders could be deleted without any ill effects.

…look for a .pacnew file.

Where should that file be located? I tried looking for it at /etc/xdg/tumbler but there is only one file there, tumbler.rc.

I could find pacman.conf.pacnew file located in /etc
If that is the file you meant, what should I do with it?

That is for pacman, See here .
Back to tumbler.rc . If you open it with i.e. nano , you can set your needed max. file size to 0 (zero). That means no size restriction.
Hope that works for you.

Ok, I changed the MaxFileSize to 0 for the following plugins in that file:

RawThumbnailer, JPEGThumbnailer, PixbufThumbnailer, FfmpegThumbnailer, GstThumbnailer.

When the system is starting, It still takes a very long time between typing your admin pass and the time when it will show the selected desktop image along with the icons, usually 2-3 minutes (it used to be 20 seconds). The icons sometimes appear as thumbnails (as it should), but more often they appear as generic icons.

Any ideas what else I could try? Basically I only put the contents of .cache/thumbnails/large and .cache/thumbnails/normal into trash, but now I can’t restore them because it kinda freezes when it asks me if I want some files to be replaced. And then I have to do a hard restart…

…see @vcottineau’s post “system mainenance”.