Three error before DSL connection succeed

I have sometimes to connet to the internet (without my router) directly with the DSL modem. I had created a new connection with KDE plasma ‘system settings’ UI tool.
My only changes in the props. to remove not needed authentication types in the third tab ‘PPP’, only PAP is checked now. (but it is not influences the process)

It is working, but during all connection process I receive three error message before the connection succeed (and it lasts more than a half minute):

2 X I see (in a system message) ‘PPP error occurs’
1 X ‘DSL connection deactivated’
1 X ‘DSL connection activated’

There is the two row from error log (sudo journalctl -p 3 -xb) what I found related with PPP:
máj 30 08:55:30 Mani pppd[849]: No secret found for PAP login
máj 30 08:56:03 Mani pppd[1933]: Cannot determine ethernet address for proxy ARP

Maybe need some tuning in the connection config file, where it is?
Thank you for any idea!

I tried my old Ubuntu 20.04.6 LTS (what I used before Manjaro) and it is connect (with the DSL connect) without hesitating. I did not change its properties, only set the user / pw and on ‘PPP’ only the PAP checked (as on my Manjaro).
Where is the config file or other place to can compare them?

Hi @Imre,

According to my understanding, the configuration is in


Hope this is what you’re looking for!

Thank you Mirdarthos,
I found a difference in /etc/ppp/options at row 208.
‘proxyarp’ was commented out in Ubuntu.
I tried it (comment out like ‘# proxyarp’) and error come at boot like before.

If it still happens, then I don’t know. Especially since the only connection I ever used on Linux, is ethernet. I never had to do anything else because I set my stuff up so that it isn’t necessary.

I found the solution (a workaround).
If I reset the password storing methot in the system settings/network/connections/ my adsl conn./DSL tab to “save password to the all users (not secretly)” the problem gone!!!

In my opinion it is a bug, the system can not decode the PAP password during boot.
If I disconnect and reconnect, the error messages does not appeared before ‘activated’.

This is intentional and not a bug, the password is saved in the users keyring. The keyring is only opened at login. If you need the password before the user logins or accessable by multiple users, it needs to be stored unencrypted on the system. Of course the filesystem can be encrypted, if saving in plain text is a problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.