This folder can't be shared because " does not exist

When I try to share a folder in kde over samba I get this error:

How do I fix it?

What is the “real” name of the folder ?

Does it contain spaces ?

Does it contain special characters like “üùû…” ?

Have you an unaligned " in your config ?

i found out smb.conf didn’t exist at all.

Also full name of the folder I want to sahre: /run/media/rabcor/04fa524d-05a5-48d3-8ef7-fd6661d60bee/Shared/

After setting up a default smb.conf error changed to this:

Seems like samba is just not set up at all on manjaro by default

created that folder, fixed it’s permissions and now i get this:

I tried creating an entry for it in smb.conf but it doesn’t work

Follow this, this should help:

Samba - ArchWiki

Did you already :mag: the forum for “samba” ?

Smh, that’s what I’m doing, but I can’t help but be a bit disappointed, the windows users can share files in like 5 clicks.

Why isn’t this set up properly out of the box on manjaro?

I went for the NFS route since it seemed easier but the transfer speeds turned out to be outrageously slow.

I just need to transfer files from 1 pc to another, it shouldn’t be as hard as rocket science…

I can’t tell you why - it apparently just isn’t. :man_shrugging:

It’s not quite that hard, honestly.
Just follow the wiki.

I run xfce with thunar -shares-plugin, but I had an issue similar with one folder that could not be shared. It turned out the item in /var/lib/samba/usershare/ needed to be owned by the user(not root)

Didn’t solve the usershares are disabled error unfortunately.

@Nachlese I know, I’m just throwing a tantrum cuz i needed this to happen fast, and there was no way for that to happen, file sharing on linux is like a specialized skill relying on esoteric knowledge. This ain’t even my first time, I’ve set up file sharing on linux before a couple times, I’m an experienced linux user even, if I’m struggling with this an average user has little to no hope of setting this up. It’s just frustrating. But since I missed my window and couldn’t get this set up in time I now have time to comb over wikis and test various configurations until I can get this working to a satisfactory standard…

I’m just disappointed, in manjaro devs for not having this set up out of the box, and in samba devs for not making it user friendly (at least it’s server administrator friendly I guess…) But I’ll figure this out now that I’m not in a rush.

If you do not need to share, but only to transfer some files:

I Do use sshfs. (sshd + ssh +mc)

It is secure (with keys), fast, and easy to use if you know to use ssh.

1 Like

It can be even easier (as a quick one time solution) with python http.server …
for example like this here - have used it many times:

Python SimpleHTTPServer - Python HTTP Server | DigitalOcean

a quick and easy file transfer solution … just change into the directory where the files are located and issue the command

python3 -m http.server 9000

and have access to these files via any browser …


This is actually incredible

neat “hack” I’d say :nerd_face:
to rather easily accomplish a goal
without having to set up a samba or ssh or nfs server
just to share some files …

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.