Thinkpad T495 does not wakeup from sleep after using graphic heavy app

Whenever I use a graphics heavy application like Darktable my laptop can’t wake up from sleep anymore, it only happens after using darktable, after forcing a restart the external monitor is not detected and the laptop monitor has the resolution 640x480, I tried multiple 5.x and 6.1.x kernels and its the same issue, I suspect its related to [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:56:crtc-0] flip_done timed out (#1000) · Issues · drm / amd · GitLab but I’m not sure.

I assume its related to the GPU state not being cleared correctly, or something related to OpenCl but I’m not sure how to even start debugging that, I tried to looking at multiple logs or journalctl but I don’t see anything related to suspend.

Kernel: 6.1.12-1-MANJARO
Shell: zsh 5.9
Resolution: 1920x1080, 1920x1080
DE: Plasma 5.26.5
WM: KWin
CPU: AMD Ryzen 5 PRO 3500U w/ Radeon Vega Mobile Gfx (8) @ 2.100GHz
GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Series

$lspci -k | grep -EA3 ‘VGA|3D|Display’

06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] (rev d2)
Subsystem: Lenovo Device 5125
Kernel driver in use: amdgpu
06:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller